QNX RTP with @home cable modem?

Hello,
I’ve been trying to get Qnx Rtp to work properly with my cable modem.

I’m not sure where the problem is, but it appears that the network
card is recognized (D-LINK DE-528CT), that the drivers are installed
and working, etc. In other words, it appears to pass all the tests in
in the troubleshooting part of the docs.

I can ping my own IP (my PC has a static IP for the cable modem) but I
am unable to ping anything esle. The message is “Host is down” or
something like that.

I ran nicinfo, and everything seemed to look OK, except that “Lan=0”.

(I’m sort of typing lots of stuff from memory because I have to reboot
into windows to post to this newsgroup).

Any hints would be appreciated…

Derek.

“Derek Ross” <derekr@escape.ca> wrote in message
news:8voq2u$29s$1@inn.qnx.com

Hello,
I’ve been trying to get Qnx Rtp to work properly with my cable modem.

I’m not sure where the problem is, but it appears that the network
card is recognized (D-LINK DE-528CT), that the drivers are installed
and working, etc. In other words, it appears to pass all the tests in
in the troubleshooting part of the docs.

I can ping my own IP (my PC has a static IP for the cable modem) but I
am unable to ping anything esle. The message is “Host is down” or
something like that.

I ran nicinfo, and everything seemed to look OK, except that “Lan=0”.

(I’m sort of typing lots of stuff from memory because I have to reboot
into windows to post to this newsgroup).

Any hints would be appreciated…

Did you provide a Gateway and nameserver?

Derek.

Did you provide a Gateway and nameserver?

Yes, I used winpicfg in Win98 to get my DNS, IP address, host name,
subnet mask, default gateway, etc…

My IP address is static, so I don’t have to worry about DHCP, as far
as I know (although winipcfg does indicate that I have a DHCP server).

Should I post the results of pci and nicinfo?

Derek.

Here is the pci and nicinfo for my system.
(The ethernet ID looks a little strange, not sure what that means).

Thanks,
Derek.


Results of pci

PCI version    = 2.10

Class          = Display (VGA)
Vendor ID      = 8086h, Intel Corporation
Device ID      = 7121h, 82810 Graphics Device
PCI index      = 0h
Mem Address    = f8000000h enabled
Mem Address    = f4000000h enabled
PCI Int Pin    = INT A
Interrupt line = 10

Class          = Mass Storage (IDE)
Vendor ID      = 8086h, Intel Corporation
Device ID      = 2411h, 82801AA IDE Controller
PCI index      = 0h
IO Address     = 10a0h enabled
PCI Int Pin    = NC
Interrupt line = 0

Class          = Multimedia (Audio)
Vendor ID      = 127ah, Rockwell Semiconductor Systems
Device ID      = 4320h, Unknown Unknown
PCI index      = 0h
IO Address     = 0h disabled
PCI Int Pin    = INT A
Interrupt line = no connection

Class          = Network (Ethernet)
Vendor ID      = 10ech, Realtek Semiconductor
Device ID      = 8029h, RTL8029 NE2000 compatible Ethernet
PCI index      = 0h
IO Address     = 7f00000h enabled
PCI Int Pin    = INT A
Interrupt line = 5

Results of nicinfo

NE2000 Ethernet Controller
Physical Node ID … AA0AAA 0AAA0A
Current Physical Node ID … AA0AAA 0AAA0A
Media Rate … 10.00 Mb/s half-duplex UTP
MTU … 1514
Lan … 0
I/O Port Range … 0x7F00000 → 0x7F0001E
Hardware Interrupt … 0x5

Total Packets Txd OK … 0
Total Packets Txd Bad … 0
Total Packets Rxd OK … 0
Total Rx Errors … 0

Tx Collision Errors … 0
Tx Collisions Errors (aborted) … 0
Carrier Sense Lost on Tx … 0
FIFO Underruns During Tx … 0
Tx defered … 0
Out of Window Collisions … 0
FIFO Overruns During Rx … 0
Alignment errors … 0
CRC errors … 0

/** PhEDIT attribute block
0:1968:default:-3:-3:0
** PhEDIT attribute block ends (-0000096)**/

“Derek Ross” <derekr@escape.ca> wrote in message
news:8vp5qn$cli$1@inn.qnx.com

Here is the pci and nicinfo for my system.
(The ethernet ID looks a little strange, not sure what that means).

It’s indeed very strange, something is definitely wrong. I have no
idea what though ;-( Issue with the realtek??

Thanks,
Derek.


Results of pci

PCI version    = 2.10

Class          = Display (VGA)
Vendor ID      = 8086h, Intel Corporation
Device ID      = 7121h, 82810 Graphics Device
PCI index      = 0h
Mem Address    = f8000000h enabled
Mem Address    = f4000000h enabled
PCI Int Pin    = INT A
Interrupt line = 10

Class          = Mass Storage (IDE)
Vendor ID      = 8086h, Intel Corporation
Device ID      = 2411h, 82801AA IDE Controller
PCI index      = 0h
IO Address     = 10a0h enabled
PCI Int Pin    = NC
Interrupt line = 0

Class          = Multimedia (Audio)
Vendor ID      = 127ah, Rockwell Semiconductor Systems
Device ID      = 4320h, Unknown Unknown
PCI index      = 0h
IO Address     = 0h disabled
PCI Int Pin    = INT A
Interrupt line = no connection

Class          = Network (Ethernet)
Vendor ID      = 10ech, Realtek Semiconductor
Device ID      = 8029h, RTL8029 NE2000 compatible Ethernet
PCI index      = 0h
IO Address     = 7f00000h enabled
PCI Int Pin    = INT A
Interrupt line = 5

Results of nicinfo

NE2000 Ethernet Controller
Physical Node ID … AA0AAA 0AAA0A
Current Physical Node ID … AA0AAA 0AAA0A
Media Rate … 10.00 Mb/s half-duplex UTP
MTU … 1514
Lan … 0
I/O Port Range … 0x7F00000 → 0x7F0001E
Hardware Interrupt … 0x5

Total Packets Txd OK … 0
Total Packets Txd Bad … 0
Total Packets Rxd OK … 0
Total Rx Errors … 0

Tx Collision Errors … 0
Tx Collisions Errors (aborted) … 0
Carrier Sense Lost on Tx … 0
FIFO Underruns During Tx … 0
Tx defered … 0
Out of Window Collisions … 0
FIFO Overruns During Rx … 0
Alignment errors … 0
CRC errors … 0

/** PhEDIT attribute block
0:1968:default:-3:-3:0
** PhEDIT attribute block ends (-0000096)**/

Hello,

In your existing Wndws setup, lookup the hostname. Use this hostname in
the network configuration in QNX RTP.

@home DHCP server needs a valid hostname with your cable-modem MAC
address…

Also see the Linux Cable-HOWTO, where I got the above info from.

Good luck,

Leon.

Some ISP use PPPoE. If that is your case there isn’t much
you can do at the moment aside from getting a home gateway
that support PPPoE.

Other option is to wait since QSSL is working on PPPoE for NTO.

“Leon Woestenberg” <leon.woestenberg@gmx.net> wrote in message
news:8vsdhj$goh$1@inn.qnx.com

Hello,

In your existing Wndws setup, lookup the hostname. Use this hostname in
the network configuration in QNX RTP.

@home DHCP server needs a valid hostname with your cable-modem MAC
address…

Also see the Linux Cable-HOWTO, where I got the above info from.

Good luck,

Leon.