Lpd - "can scan"

Hi:

I am trying to setup lpd,but I am getting a strange error being reported by
syslogd.

/etc/printcap :
"lp|lp:
:lp=/dev/ser1:
"
run lpd:
“lpd -l”

The spooler directory exists! Ihave even changed lpr to be of the daemon
group (chgrp daemon /usr/bin/lpr).
When I try to print ( date | lpr -Plp ) I get syslogd reporting “lp: can’t
scan /usr/spool/output/lpd”

What am I missing ?

TIA Andy.

Surely someone has seen this problem… I cant seem to get away from it, it
happens here and home.

If no-one has seen this behaviour- then I am definitely doing something
wrong with my startup and configuration. Any suggestions or samples ?

Andy.

Andy <andy@symmetry.com.au> wrote in message
news:981ai9$hvg$1@inn.qnx.com

Hi:

I am trying to setup lpd,but I am getting a strange error being reported
by
syslogd.

/etc/printcap :
"lp|lp:
:lp=/dev/ser1:
"
run lpd:
“lpd -l”

The spooler directory exists! Ihave even changed lpr to be of the daemon
group (chgrp daemon /usr/bin/lpr).
When I try to print ( date | lpr -Plp ) I get syslogd reporting “lp: can’t
scan /usr/spool/output/lpd”

What am I missing ?

TIA Andy.

Just off the top of my head - does the directory /usr/spool/output/lpd
exist? If not, i think that you have to create it first.

Wayne

Previously, Andy wrote in qdn.public.qnxrtp.installation:

Surely someone has seen this problem… I cant seem to get away from it, it
happens here and home.

If no-one has seen this behaviour- then I am definitely doing something
wrong with my startup and configuration. Any suggestions or samples ?

Andy.

Andy <> andy@symmetry.com.au> > wrote in message
news:981ai9$hvg$> 1@inn.qnx.com> …
Hi:

I am trying to setup lpd,but I am getting a strange error being reported
by
syslogd.

/etc/printcap :
"lp|lp:
:lp=/dev/ser1:
"
run lpd:
“lpd -l”

The spooler directory exists! Ihave even changed lpr to be of the daemon
group (chgrp daemon /usr/bin/lpr).
When I try to print ( date | lpr -Plp ) I get syslogd reporting “lp: can’t
scan /usr/spool/output/lpd”

What am I missing ?

TIA Andy.



\


Wayne Fisher, Team Leader - Core Software | Focus Automation Systems Inc.
#include <std/disclaimer.h> | 101 Randall Drive
mailto:Wayne.Fisher@focusautomation.com | Waterloo, Ontario. N2V 1C5
http://www.focusautomation.com | (519)746-1100 Fax:(519)746-1170

Wayne:
Thanks for the reply.

Tried that.
I even changed the directory by creating a new dir and putting it
"sd=/tmp/spool: in the printcap. The error message changed accordingly.
I am pinning down the error : if the queue exisits but the printer is
disabled - then I dont get the error. When I enable the printer then I get
the error. So it happens when lpd attempts to access spooled data, rather
than when lpd spools the data.

Lpd hates me, I can feel it. :slight_smile:

Andy.

Wayne Fisher <wayne@focus-systems.on.ca> wrote in message
news:Voyager.010308153049.30803A@ntcad-2.focus-systems.on.ca

Just off the top of my head - does the directory /usr/spool/output/lpd
exist? If not, i think that you have to create it first.

Wayne

Previously, Andy wrote in qdn.public.qnxrtp.installation:
Surely someone has seen this problem… I cant seem to get away from it,
it
happens here and home.

If no-one has seen this behaviour- then I am definitely doing something
wrong with my startup and configuration. Any suggestions or samples ?

Andy.

Andy <> andy@symmetry.com.au> > wrote in message
news:981ai9$hvg$> 1@inn.qnx.com> …
Hi:

I am trying to setup lpd,but I am getting a strange error being
reported
by
syslogd.

/etc/printcap :
"lp|lp:
:lp=/dev/ser1:
"
run lpd:
“lpd -l”

The spooler directory exists! Ihave even changed lpr to be of the
daemon
group (chgrp daemon /usr/bin/lpr).
When I try to print ( date | lpr -Plp ) I get syslogd reporting “lp:
can’t
scan /usr/spool/output/lpd”

What am I missing ?

TIA Andy.






\

Wayne Fisher, Team Leader - Core Software | Focus Automation Systems Inc.
#include <std/disclaimer.h> | 101 Randall Drive
mailto:> Wayne.Fisher@focusautomation.com > | Waterloo, Ontario. N2V 1C5
http://www.focusautomation.com > | (519)746-1100
Fax:(519)746-1170

Andy wrote:

Wayne:
Thanks for the reply.

Tried that.
I even changed the directory by creating a new dir and putting it
"sd=/tmp/spool: in the printcap. The error message changed accordingly.
I am pinning down the error : if the queue exisits but the printer is
disabled - then I dont get the error. When I enable the printer then I get
the error. So it happens when lpd attempts to access spooled data, rather
than when lpd spools the data.

Lpd hates me, I can feel it. > :slight_smile:

Andy.

It’s not you, Andy…lpd stands for “lazy printer daemon” - it will do anything
to get out of working. :slight_smile:
I would suggest checking the ownership and permissions of the
/usr/spool/output/lpd directory. You must have eXecute permission on a
directory to descend into it and “scan” it…
Hope this helps, I know setting up lpd can be a bear.

Phil Olynyk

Wayne Fisher <> wayne@focus-systems.on.ca> > wrote in message
news:> Voyager.010308153049.30803A@ntcad-2.focus-systems.on.ca> …

Just off the top of my head - does the directory /usr/spool/output/lpd
exist? If not, i think that you have to create it first.

Wayne

Previously, Andy wrote in qdn.public.qnxrtp.installation:
Surely someone has seen this problem… I cant seem to get away from it,
it
happens here and home.

If no-one has seen this behaviour- then I am definitely doing something
wrong with my startup and configuration. Any suggestions or samples ?

Andy.

Andy <> andy@symmetry.com.au> > wrote in message
news:981ai9$hvg$> 1@inn.qnx.com> …
Hi:

I am trying to setup lpd,but I am getting a strange error being
reported
by
syslogd.

/etc/printcap :
"lp|lp:
:lp=/dev/ser1:
"
run lpd:
“lpd -l”

The spooler directory exists! Ihave even changed lpr to be of the
daemon
group (chgrp daemon /usr/bin/lpr).
When I try to print ( date | lpr -Plp ) I get syslogd reporting “lp:
can’t
scan /usr/spool/output/lpd”

What am I missing ?

TIA Andy.






\

Wayne Fisher, Team Leader - Core Software | Focus Automation Systems Inc.
#include <std/disclaimer.h> | 101 Randall Drive
mailto:> Wayne.Fisher@focusautomation.com > | Waterloo, Ontario. N2V 1C5
http://www.focusautomation.com > | (519)746-1100
Fax:(519)746-1170