USB mouse problems

I’m trying to get my Logitech iFeel MouseMan Optical up and running on
QNX RTP and am having difficulty. As root, from the command line, I
type the following:

devu-uhci &
devu-mouse &

After the uhci command, I see “usb” appear in /dev. However, I should
also expect to see /dev/usbmouse0, but it never appears there.

By the way, I also have a regular ps/2 mouse plugged in the system. I
don’t know if that’s causing problems. I don’t know where my
mouse/keyboard is getting started when I boot up, so I don’t know how to

boot up without enabling the ps/2 mouse. I know how to disable the ps/2

mouse and how to restart it (via inputtrap).

Even when I disable the mouse, then run the devu commands, the usbmouse
still doesn’t appear.
Any help would be appreciated. Thanks!

Neville

Hi Neville,

Make sure you are running as “root” also try unplugging and plugging
back in the mouse before you run the driver. Also try both USB ports
(if avail).

Erick.


Neville Bonwit <neville@erg.sri.com> wrote:

I’m trying to get my Logitech iFeel MouseMan Optical up and running on
QNX RTP and am having difficulty. As root, from the command line, I
type the following:

devu-uhci &
devu-mouse &

After the uhci command, I see “usb” appear in /dev. However, I should
also expect to see /dev/usbmouse0, but it never appears there.

By the way, I also have a regular ps/2 mouse plugged in the system. I
don’t know if that’s causing problems. I don’t know where my
mouse/keyboard is getting started when I boot up, so I don’t know how to

boot up without enabling the ps/2 mouse. I know how to disable the ps/2

mouse and how to restart it (via inputtrap).

Even when I disable the mouse, then run the devu commands, the usbmouse
still doesn’t appear.
Any help would be appreciated. Thanks!

Neville