LPD woes

I am running lpd in neutrino. Setting up an /etc/printcap file that allows
me to print to a remote machine. Whenever I use LPR syslog reports “can’t
scan /usr/spool/output/lpd/hp” ie my spool file.

Anybody have any idea what gives ? Sounds like a permissions issue, or
ownership.

Cheers Matt

Shouldn’t that be /var/spool? Perhaps we’ve got our default paths mixed
up…I’ll check our lpd code.

Kris

matt mchugh <mattgreeneggswithspam@ruzz.com> wrote:

I am running lpd in neutrino. Setting up an /etc/printcap file that allows
me to print to a remote machine. Whenever I use LPR syslog reports “can’t
scan /usr/spool/output/lpd/hp” ie my spool file.

Anybody have any idea what gives ? Sounds like a permissions issue, or
ownership.

Cheers Matt


Kris Warkentin
kewarken@qnx.com
(613)591-0836 x9368
“You’re bound to be unhappy if you optimize everything” - Donald Knuth

Apparently there was a bug report about this that has recently been fixed.
It may show up in the next release if it made it into CVS in time for the
GA release. As an alternate solution, you could ask your printcap to use
/var/spool. BTW, the problem is most likely that you don’t actually have
a /usr/spool/output/lpd directory…did you check this?

cheers,

Kris.

Kris Eric Warkentin <kewarken@qnx.com> wrote:

Shouldn’t that be /var/spool? Perhaps we’ve got our default paths mixed
up…I’ll check our lpd code.

Kris

matt mchugh <> mattgreeneggswithspam@ruzz.com> > wrote:
I am running lpd in neutrino. Setting up an /etc/printcap file that allows
me to print to a remote machine. Whenever I use LPR syslog reports “can’t
scan /usr/spool/output/lpd/hp” ie my spool file.

Anybody have any idea what gives ? Sounds like a permissions issue, or
ownership.

Cheers Matt


Kris Warkentin
kewarken@qnx.com
(613)591-0836 x9368
“You’re bound to be unhappy if you optimize everything” - Donald Knuth


Kris Warkentin
kewarken@qnx.com
(613)591-0836 x9368
“You’re bound to be unhappy if you optimize everything” - Donald Knuth

matt mchugh <> mattgreeneggswithspam@ruzz.com> > wrote:
I am running lpd in neutrino. Setting up an /etc/printcap file that allows
me to print to a remote machine. Whenever I use LPR syslog reports “can’t
scan /usr/spool/output/lpd/hp” ie my spool file.

Anybody have any idea what gives ? Sounds like a permissions issue, or
ownership.

There was an issue within lpd causing this error, and so the next beta should
contain the fix.

ron