mout -T io-net seems to work but complains

I run mount -T io-net -o “busdevice=0xxxx,busvendor=0xxxx,busindex=0x0” /lib/dll/devn-
After I run this command I get the error message
mount: can’t mount / (type io-net)
mount:Possible reason: No such device

What is strange is this command seems to work - I can see en0 coming up after I run this command. I then run dhcp.client - en0 gets an IP Address. Can anyone please tell me why I get this message? what should I do to remove it?
Thank you

You should not place quotes around options:
mount -T io-net -o busdevice=0xxxx,busvendor=0xxxx,busindex=0x0 /lib/dll/

The driver uses getsubopt() to parce options - the first suboption will start with " mark.
In general - if driver fails to parce options specified at startup - it should go on as there were no options specified.
In your case - the driver fails on options but scans the bus for known devices nad returns from its initialisation routine,indicating he was loaded with options he could not undestand :slight_smile:
But this does not prevent it from working properly.
Do you really need to specify options?
Try loading the driver with no options at all

Thank you
There are two reasons why I had to specify the options

  • there are two 82546GB
  • using for a 82546GB Network Controller - without the busdevice and busvendor it does not work

Here is the final script that works

  • QNX / Intel docs say that 82544 device driver can be used for 82546GB
    • Make sure /lib/dll/ exists - if it does not it means installation was not done properly
    • Run pci and make sure the two network controllers show up -
      - also note down the Device ID (0x1079) and Vendor ID (0x8086)
    • Run these commands to set the ETH interface
      slay -f io-net
      io-net -d i82544 vid=0x8086,did=0x1079 -p tcpip
      waitfor /dev/socket
      dhcp.client -I -u &
      netmanager &
    • At the end of these commands run /sbin/ifconfig; you should see
      three interfaces - lo0, en0, en1. en0 and en1 should have valid IP
    • if you want to assign static IP the command is
      ifconfig en0 x.x.x.x netmask y.y.y.y (similarly for en1)
  • Run Ping from your PC to these interfaces