Help using NFS please.

I want to upgrade 6.0B to 6.1. I have a target (embedded) system with
6.0B and a host PC with 6.1 running. The target system has no CD drive
but is networked. I have downloaded and burned the bigger 6.1 CD and
can put it in the host CD drive. I want to map the host system cd drive
using NFS and upgrade from there.

On the qnx 6.1 machine, I run the following script:

slay -f -Q io-net dhcp.client portmap inetd
io-net -ptcpip -ppppmgr
mount -T io-net -o connector=1 devn-el900.so
mount -T io-net host=labqnx2.aub.boeing.com npm-qnet.so
dhcp.client
portmap
inetd -d &
nfsd &

my /etc/exports file contains:

/cd0 136.241.146.59

(that is the IP address of the QNX 6.0B client)

On the QNX 6.0 machine, I run the same script, but without nfsd (and
with a different name). Then I
type:

fs-nfs2 -t 136.241.146.38:/ /labqnx2

That is the IP address of the QNX 6.1 machine. /labqnx2 is created on
the 6.0 machine but
it is not a directory. Any idea what I am doing wrong?

BTW, even though I run dhcp.client, the name server on our intranet does
not seem to work with the qnx machines, so I have to refer to them by IP
address. Of course this is dangerous because the IP addresses could
change. Any ideas why dhcp is not working?



Thanks.