RTP 6.2 3rd Party...

Andrew Thomas <andrew@cogent.ca> wrote:

I can see why this may be a better solution for the library paths, but
there are plenty of open source projects out there that make assumptions
about X11 bins being in /usr/X11R6. I know that some configure scripts
check both /usr and /opt, but I still bump into problems that are best
addressed with the symlink. Out of curiosity, why doesn’t the X11
install get mapped into the /usr hierarchy the way many of the other
installations do?

given those problems, maybe we can make the next X build into /usr/X11R6,
what do you think cdm?

Better to take the advice from the FAQ found here:



Thanks, Chris. I’ve never even heard of setconf, so I would not have found

this on my own.


Hey Dale

A couple of suggestions on how to do this:

You can change the ph script to
-export /opt/X11… for PATH and LD_LIBRARY_PATH
-start XPhoton & instead of Xphoton -once &
-do NOT start gtwm (if you even have it)
(one of the reasons the name was changed…)

or manually

add /opt/X11R6/bin to PATH and /opt/X11R6/lib to LD_LIBRARY_PATH
XPhoton &

Hope this helps


“Dale Sherwood” <dsherwoo@nyab.com> wrote in message

Pete Eddy wrote in message …
…The 3rd Party disk is real handy, it saves a lot of time with
installations. However some of the packages give me errors installing,
say the can’t resolve dependancies. For example it can’t find
when resolving dependancies. Does anyone know what to do about this? I
couldn’t get emacs or dia to work, and couple other apps. I will post
simptoms later if I no one else has seen this problem.


I too am having various problems with 6.2 third-party apps. Regarding X
Windows, I found that manually creating the following symlink helps with

ln -s /opt/X11R6 /usr/X11R6

X apps apparently do not run with 6.2 because, unlike with 6.1, XPhoton is
not automatically launched (by Photon?) as “XPhoton -once” when you run
X app. Instead, if you first launch X by typing

XPhoton &

then you can run your X apps. I have been unable to find another solution.


Chris McKillop wrote:

Better to take the advice from the FAQ found here:



I tried using the setconf/on method documented in the FAQ. However, when
I run “on -t /dev/con1 /opt/X11R6/bin/XPhoton” I get this error:

unknown symbol: netmgr_path
Could not resolve all symbols

What does this mean?

  • It does this no matter which command I try to run on /dev/con1, so it
    does not seem to be related to XPhoton.

  • The device /dev/con1 exists.