How to get QNX 6.3 running as LiveCD?

Hi folks,

I’m new to QNX, but have the pleasure to work with it for the next 6 months since I have to work with it in University. I just wanted to run the QNX 6.3 Installation CD as a LiveCD on my ASUS-Notebook. The messages were about this:

Unable to mount a qnx4 filesystem as /fs/hd0-qnx4 on /dev/hd079 (Corrupted filesystem detected)

Then I was asked to choose betweed the boot opitons F2/F3. So I chose F2 and had the following messages:

[code]No vaild commertial license found […]

/etc/system/config/graphics-traplist: No such file or directory
/etc/rc.d/rc.local: No such file or directory
/etc/rc.d/rc.local: No such file or directory

… and then the system freezed. No soft reboot worked, only the power button gave new life to my laptop. Has anyone an idea of what’s wrong? It seems that QNX detects my hdd, so difficulties with dma shouldn’t be the problem.


Hi !

Maybe you have burnt in the wrong way your cd check the md5sum, find in google md5summer for example to do this from windows.

When the cd be up and the install too in the login put root and that it is :slight_smile: Ximo

Hi Ximo,

thanks for the reply, but the md5-sum from the iso-image is the same as shown in the download section. I burnt my CD with nero and applied a verifying pass after the burning - so I think the CD should be ok.

Has someone any other suggestions?

Merci so far…


Do you already have some QNX stuff on the hard disk? I thought you were trying to use liveCD without installing onto the hard disk. You might want to “clean” up your hard disk partition a bit first.

Hi noc,

thanks for your answer.

No, I haven’t. The thing is that I want to install qnx on an extended partition which isn’t supported by the standard installation from qnx (or is it??). I read your suggestions to create a partition with fdisk and the ID 79 as described in the thread

This partition is empty, I wanted to format it with dinit (issue 1 in your description)

Bye so far -

Try to play with different boot options:

During the CD boots, you will see “Press space bar …” and hit “space”.
One thing to try is:
F1 - safe mode, then F3 - no photon. then “enter”, “enter” back to booting.
when prompted, choose F2 -Run from CD. If you are lucky, you will get a login screen and you can login as “root” with no password.