Problem with installation - QNX 6.3

Hello,

I downloaded iso image of QNX 6.3 (Windows Host), I burned the CD
and tried to install it on empty FAT partition. At the end of installation
i got a meesage that it did’t finish with succsess. It’s somthing like:
There were problems with copying files…, missing files… I burned
another CD and the same problem occured, I tried to install it using
Virtual CD - the same problems again. My iso image is broken or I do
something wrong??

                                                 Thanks for your help!
                                                 duck

Did you check the md5sum with a programme like md5sum.exe against the given md5sum from the download page?

You are aware that the “Windows Host” will NOT allow you to run QNX, right?
It is just a development tool that allows you to write programs that can be run on a QNX host.

Hello,

Thank you. I’m a beginner and I thought that I can install QNX 6.3
under windows like I did erlier with QNX 6.2.1 :confused:
Can you tell me how I can install QNX 6.3? Shall I download
QNX Neutrino RTOSx86 host?

duck

Yes, you need to download QNX Neutrino RTOSx86 host.

BTW, QNX 6.3 doesn’t support installing into a FAT partition anymore. You can still do it manually with some tweaks, but since you are a newbie, I won’t suggest that. Leave an empty slot on your disk so that QNX can create and install into its own partition.

Ok, I will do it :slight_smile: And how will I choose the system after installation.
QNX will create a menu for me or I have to do it on my own?
( I have now only Win XP )

Thank you again noc!

During QNX installation, it will offer you to install the “boot loader”. It is not as nice as a menu, but you will see a ? during boot where you can type in the partition number that you want to boot: windows or qnx. (you can find out the corresponding partition numbers using “fdisk” in qnx).

Or you can use other boot managers such as grub, lilo. Search this forum for details.

Duck, did you ever get this working?

I had a similar problem, that I’ve not yet fixed.

I described it in this thread.

I downloaded an ISO and booted it as a live system, i.e. running straight off the cd-rom without installing to a hard drive.

This worked, so I tried to install to (hd2,0). I got some error messages, but the installation process continued to the end.

When I tried to boot
by telling the BIOS to boot from this disc
by telling GRUB to chainload the QNX bootloader
the boot failed (in two subtly different ways).

As advised in the thread mentioned above, I verified the md5 checksum. OK.

I’m no nearer to solving this yet.

Beef.

Update: 14 June 2006.

I gave the whole disc to QNX, installed, and used GRUB with chainloader +1 to sucessfully boot QNX.

See this post for details.