using fs-cifs

Hello,

I tried the command “fs-cifs” in order to mount networks filesystems via the
Microsoft protocol. Using Neutrino 2.0 or Neutrino 2.1, it seems to work
fine
if we connect with a Windows 9x platform but when a Windows NT workstation
(or server) is being used, we dive in the abysses of the windows’ troubles,
in other words it doesn’t work at all!!!
I know that you must indicate to fs-cifs the netbios name of the machine if
you want to connect to a microsoft OS.

  1. Is there a parameter i 've forgotten to make it success?
  2. Does the next patch A (which is normally coming soon…I hope…) will
    answer to this problem ?
    Thanks. Vincent
    vcelerier@logisonic.fr

Vincent Celerier <vcelerier@logisonic.fr> wrote:

Hello,

I tried the command “fs-cifs” in order to mount networks filesystems via the
Microsoft protocol. Using Neutrino 2.0 or Neutrino 2.1, it seems to work
fine
if we connect with a Windows 9x platform but when a Windows NT workstation
(or server) is being used, we dive in the abysses of the windows’ troubles,
in other words it doesn’t work at all!!!
I know that you must indicate to fs-cifs the netbios name of the machine if
you want to connect to a microsoft OS.

  1. Is there a parameter i 've forgotten to make it success?
  2. Does the next patch A (which is normally coming soon…I hope…) will
    answer to this problem ?
    Thanks. Vincent
    vcelerier@logisonic.fr

My configuration for mounting a NT box:

fs-cifs //NTW437F:10.1.0.183:/C /cifs/nt/dc apkleywegt passwd

Use the simplist configuration for the share on the Windows side,
i.e. give full permissions to everybody to start.

Allan Kleywegt <apkleywegt@qnx.com> a écrit dans le message :
91t6p9$rdu$1@nntp.qnx.com

Vincent Celerier <> vcelerier@logisonic.fr> > wrote:
Hello,

I tried the command “fs-cifs” in order to mount networks filesystems via
the
Microsoft protocol. Using Neutrino 2.0 or Neutrino 2.1, it seems to work
fine
if we connect with a Windows 9x platform but when a Windows NT
workstation
(or server) is being used, we dive in the abysses of the windows’
troubles,
in other words it doesn’t work at all!!!
I know that you must indicate to fs-cifs the netbios name of the machine
if
you want to connect to a microsoft OS.

  1. Is there a parameter i 've forgotten to make it success?
  2. Does the next patch A (which is normally coming soon…I hope…)
    will
    answer to this problem ?
    Thanks. Vincent
    vcelerier@logisonic.fr

My configuration for mounting a NT box:

fs-cifs file://NTW437F:10.1.0.183:/C /cifs/nt/dc apkleywegt passwd

Are you sharing the “c:” logical drive?

Use the simplist configuration for the share on the Windows side,
i.e. give full permissions to everybody to start.


In my case, I would like to share a directory with my file server called

Alex
(I didn’t choose the name…). So I created a directory (toto) with all
permissions
and made the command line :
fs-cifs file://ALEX:129.0.1.1:/toto /nto/export/toto user none &
And the error has been…occured, telling me in “politically correct”
language my share won’t work…
Vincent. (becomming a Microsoftphobist…)

Vincent Celerier <vcelerier@logisonic.fr> wrote:

My configuration for mounting a NT box:

fs-cifs file://NTW437F:10.1.0.183:/C /cifs/nt/dc apkleywegt passwd

Are you sharing the “c:” logical drive?

Yes.


Use the simplist configuration for the share on the Windows side,
i.e. give full permissions to everybody to start.


In my case, I would like to share a directory with my file server called
Alex
(I didn’t choose the name…). So I created a directory (toto) with all
permissions
and made the command line :
fs-cifs file://ALEX:129.0.1.1:/toto /nto/export/toto user none &
And the error has been…occured, telling me in “politically correct”
language my share won’t work…
Vincent. (becomming a Microsoftphobist…)

So your desired configuration isn’t in the simplist form.

Start with the simplist configuration if possible by sharing a logical
drive to everybody; once that works find where it breaks, if it breaks,
as you move toward the desired config.

If your able to get the simple config, but not the desired, we can look
at starting a bug report.

Vincent Celerier a écrit :

Allan Kleywegt <> apkleywegt@qnx.com> > a écrit dans le message :
91t6p9$rdu$> 1@nntp.qnx.com> …
Vincent Celerier <> vcelerier@logisonic.fr> > wrote:
Hello,

I tried the command “fs-cifs” in order to mount networks filesystems via
the
Microsoft protocol. Using Neutrino 2.0 or Neutrino 2.1, it seems to work
fine
if we connect with a Windows 9x platform but when a Windows NT
workstation
(or server) is being used, we dive in the abysses of the windows’
troubles,
in other words it doesn’t work at all!!!
I know that you must indicate to fs-cifs the netbios name of the machine
if
you want to connect to a microsoft OS.

  1. Is there a parameter i 've forgotten to make it success?
  2. Does the next patch A (which is normally coming soon…I hope…)
    will
    answer to this problem ?
    Thanks. Vincent
    vcelerier@logisonic.fr

My configuration for mounting a NT box:

fs-cifs file://NTW437F:10.1.0.183:/C /cifs/nt/dc apkleywegt passwd

Are you sharing the “c:” logical drive?


Use the simplist configuration for the share on the Windows side,
i.e. give full permissions to everybody to start.


In my case, I would like to share a directory with my file server called
Alex
(I didn’t choose the name…). So I created a directory (toto) with all
permissions
and made the command line :
fs-cifs file://ALEX:129.0.1.1:/toto /nto/export/toto user none &
And the error has been…occured, telling me in “politically correct”
language my share won’t work…
Vincent. (becomming a Microsoftphobist…)

\

I think that you first have to declare your QRTP server on your NT domain by the
NT server admin tool. Then you need to supply a valid username/password on the
NT domain to be allowed to access a NT workstation/server.
I have a share on a NT 4.0 server where I configure the access to allow the
domain users to modify and it works.
You will ever have some warnings as NT doesn’t support file date modification.
Take care to give the correct SMB NT name, the correct IP address (10.1.0. is
the default IP address for a SMB server I think, not sure, but it could work on
Unix, I wonder if it’s ok on NT!) and then the correct name of the share ,
mount point where you have the rights to create dirs, good username/passwd on
the NT server/domain.
Just a point; you NEED a password. It seems that it don’t work if your login
session don’t need a password, even if you give ‘none’ to fs-cifs.

Alain.