Cablemodem/Networking issues.

I’m a TimeWarner RoadRunner Cablemodem subscriber, and thus far,
haven’t been able to configure it to work properly. I use a Linksys
Etherfast 10/100 ethernet card, (though I didn’t see it supported on the
website, the OS detected it just fine). The service uses DHCP, and
unfortunately, provides absolutly no information about the specifications
thereof. No DHCP server to manually specify, no DHCP ID, nothing. When I
select ‘DHCP’ in phlip, save it, close the app, and re-open it, the
‘Domain name’ field in the ‘Network’ tab has been filled out with my IP
address, as verified from my Windows partition. No matter what i’ve tried,
i’ve not been able to get networking functional under the OS. (Nor sound
for that matter, using a SoundBlaster Live! Value.)

Any help would be appreciated, thanks.

Brian

Go to the URL “http://qdn.qnx.com/support/hardware/platform/network.html” - this
lists network cards supported. PNP support is different than actually
supporting the device; PNP tells the system what it is, and the OS is
responsible for finding the driver for it.

We use the SMC cards because they are easy to come by and inexpensive.

Jim

Brian Robinson wrote:

I’m a TimeWarner RoadRunner Cablemodem subscriber, and thus far,
haven’t been able to configure it to work properly. I use a Linksys
Etherfast 10/100 ethernet card, (though I didn’t see it supported on the
website, the OS detected it just fine). The service uses DHCP, and
unfortunately, provides absolutly no information about the specifications
thereof. No DHCP server to manually specify, no DHCP ID, nothing. When I
select ‘DHCP’ in phlip, save it, close the app, and re-open it, the
‘Domain name’ field in the ‘Network’ tab has been filled out with my IP
address, as verified from my Windows partition. No matter what i’ve tried,
i’ve not been able to get networking functional under the OS. (Nor sound
for that matter, using a SoundBlaster Live! Value.)

Any help would be appreciated, thanks.

Brian

Brian Robinson wrote:

I’m a TimeWarner RoadRunner Cablemodem subscriber, and thus far,
haven’t been able to configure it to work properly. I use a Linksys
Etherfast 10/100 ethernet card, (though I didn’t see it supported on the
website, the OS detected it just fine). The service uses DHCP, and
unfortunately, provides absolutly no information about the specifications
thereof. No DHCP server to manually specify, no DHCP ID, nothing. When I
select ‘DHCP’ in phlip, save it, close the app, and re-open it, the
‘Domain name’ field in the ‘Network’ tab has been filled out with my IP
address, as verified from my Windows partition. No matter what i’ve tried,
i’ve not been able to get networking functional under the OS. (Nor sound
for that matter, using a SoundBlaster Live! Value.)

Any help would be appreciated, thanks.

Brian

There’s a thread in qdn.public.qnxrtp.newuser. here is a message from
there. I don’t know if it will help you.

Previously, Mick wrote in qdn.public.qnxrtp.newuser:

eddy-vandepol@pandora.be > (Eddy Van de Pol) wrote in
1103_981123899@eddy2>:

Hi
I’m a QNX newbie, I installed tteh QNX in Wndows ME andt it works fine,
when I use my external modem i’m capable of connecting to the internet.
Recently I changed to another provider and now I use a cable modem and
DHCP, that works fine for windows and linux but with QNX I can’t use
Voyager ; My network card is Realtek and I don’t think that’s the
problem because in the network box I see that the two DNS codes of my
provider are automatically filled in Can someone give me a hint?

Thanks

The @Home network uses (an extension to?) DHCP where you must transmit
your host name along with the DHCP discovery packet. The host name is
that letter/number combination that they tell you to enter into the
host and domain fields of your Windows TCP setup. For example, mine
looks like CR123456.wlfdle1.on.wave.home.com, where CR123456 is the
host name and wlfdle1.on.wave.home.com is the domain name. If you are
using a non-windows DHCP client, it must accept the -H option and you
must give it either the whole name (CR123446.wlfdle1.on.wave.home.com)
or just the hostname portion (CR123456). You will need to experiment
to find out which. Some DHCP clients seem to have trouble with the -H
option, in which case you also need to set your hostname at the OS
level:

$ hostname CR123456.wlfdle1.on.wave.home.com
or
$ hostname CR123456

Try both.

Cheers,
Andrew