io-graphics crashed

Hi,

after MPEG-Video playing with Photon Media Player crashed io-graphics
(or one lib).
I use the rage-video driver (ATI 3D RAGE PRO AGP 2x).

message after crash:
"
ybuf0: 40100000, stride 640
ybuf1: 40126000, stride 640
/home/vanmarle/cvs/grafx/lib/disputil/vmemmgr.c ,line 249: assert
failed: handle ->flags & DISP_VM_BLOCK_INUSE
io-graphics received signal 11
IP:b04dadf6 ref: 0
symbol disp_vm_destroy_pool@libdisputil.so.1 file offeset 4a10
"

What can I do?

Bert

Bert Irmert <Bert.Irmert@bitctrl.de> wrote:

Hi,

after MPEG-Video playing with Photon Media Player crashed io-graphics
(or one lib).
I use the rage-video driver (ATI 3D RAGE PRO AGP 2x).

Are you running the latest patch?

message after crash:
"
ybuf0: 40100000, stride 640
ybuf1: 40126000, stride 640
/home/vanmarle/cvs/grafx/lib/disputil/vmemmgr.c ,line 249: assert
failed: handle ->flags & DISP_VM_BLOCK_INUSE
io-graphics received signal 11
IP:b04dadf6 ref: 0
symbol disp_vm_destroy_pool@libdisputil.so.1 file offeset 4a10
"

What can I do?

Bert

Hi Bert,

Could you run the graphics script located on my home page

staff.qnx.com/~emuis

and send me the output (emuis@qnx.com).

You will need to make the script executable (chmod +x grafxscript.rtp)

Thanks

Erick.



Bert Irmert <Bert.Irmert@bitctrl.de> wrote:

Hi,

after MPEG-Video playing with Photon Media Player crashed io-graphics
(or one lib).
I use the rage-video driver (ATI 3D RAGE PRO AGP 2x).

message after crash:
"
ybuf0: 40100000, stride 640
ybuf1: 40126000, stride 640
/home/vanmarle/cvs/grafx/lib/disputil/vmemmgr.c ,line 249: assert
failed: handle ->flags & DISP_VM_BLOCK_INUSE
io-graphics received signal 11
IP:b04dadf6 ref: 0
symbol disp_vm_destroy_pool@libdisputil.so.1 file offeset 4a10
"

What can I do?

Bert

Hi David,

My system run with latest patch (Patch A 01/2001).


David Donohoe wrote:

Bert Irmert <> Bert.Irmert@bitctrl.de> > wrote:
Hi,

after MPEG-Video playing with Photon Media Player crashed io-graphics
(or one lib).
I use the rage-video driver (ATI 3D RAGE PRO AGP 2x).

Are you running the latest patch?

message after crash:
"
ybuf0: 40100000, stride 640
ybuf1: 40126000, stride 640
/home/vanmarle/cvs/grafx/lib/disputil/vmemmgr.c ,line 249: assert
failed: handle ->flags & DISP_VM_BLOCK_INUSE
io-graphics received signal 11
IP:b04dadf6 ref: 0
symbol disp_vm_destroy_pool@libdisputil.so.1 file offeset 4a10
"

What can I do?

Bert

Hi Bert,

From the information that was sent (graphics script) it doesn’t
appear to have the latest patch installed. Could you please
verify that it is installed, by using the package installer
and going to www QNX repository and select the package manager,
this then should start to update the rest of your machine.

Thanks

Erick


Bert Irmert (Bert.Irmert@bitctrl.de) wrote:

Hi David,

My system run with latest patch (Patch A 01/2001).



David Donohoe wrote:

Bert Irmert <> Bert.Irmert@bitctrl.de> > wrote:
Hi,

after MPEG-Video playing with Photon Media Player crashed io-graphics
(or one lib).
I use the rage-video driver (ATI 3D RAGE PRO AGP 2x).

Are you running the latest patch?

message after crash:
"
ybuf0: 40100000, stride 640
ybuf1: 40126000, stride 640
/home/vanmarle/cvs/grafx/lib/disputil/vmemmgr.c ,line 249: assert
failed: handle ->flags & DISP_VM_BLOCK_INUSE
io-graphics received signal 11
IP:b04dadf6 ref: 0
symbol disp_vm_destroy_pool@libdisputil.so.1 file offeset 4a10
"

What can I do?

Bert