pccard-launch utility

hi,


I want to use pccard_launch utility to start automaticaly devb-eide server
to manage an ATA card flash memory. To do this, I write on a shell the
following command :

pccard-launch -v ‘0x400,devb-eide eide ioport=0x200,irq=5’ &

When I insert my pcmcia card devb-eide is launched
When I remove my card devb-eide is already started (I can see it with ps
utility)
When I insert my card for the second time, devb-eide is out : I see nothing
with ps utilty and my shell is out too


When I start the server on a shell all is good. I can read and write file
onto pcmcia card


could you help me


thank,

Hi,

It is not a good idea to yank out an ATA pccard without first un-mounting
the device and slaying the driver. There was a bug in pccard-launch, where
it would not launch an application if enum-pccard was running. If you slay
enum-pccard the disk driver should start successfully. Do you see the message
‘spawned /sbin/devb-eide’ when the card is inserted and pccard-launch is
run with the -v option?

Regards,

Joe


PAYRE serge <spayre@centralp.fr> wrote:

hi,



I want to use pccard_launch utility to start automaticaly devb-eide server
to manage an ATA card flash memory. To do this, I write on a shell the
following command :

pccard-launch -v ‘0x400,devb-eide eide ioport=0x200,irq=5’ &

When I insert my pcmcia card devb-eide is launched
When I remove my card devb-eide is already started (I can see it with ps
utility)
When I insert my card for the second time, devb-eide is out : I see nothing
with ps utilty and my shell is out too



When I start the server on a shell all is good. I can read and write file
onto pcmcia card



could you help me

thank,

I’ve tried more test this morning and it seems to me that all is OK.

for info :

I have the message ‘spawned /sbin/devb-eide’ when the card is inserted
I’m working on a ISA system without enum-pccard


Hardware Support Account a écrit dans le message
<9f0mqv$lfm$1@nntp.qnx.com>…

Hi,

It is not a good idea to yank out an ATA pccard without first un-mounting
the device and slaying the driver. There was a bug in pccard-launch, where
it would not launch an application if enum-pccard was running. If you slay
enum-pccard the disk driver should start successfully. Do you see the
message
‘spawned /sbin/devb-eide’ when the card is inserted and pccard-launch is
run with the -v option?

Regards,

Joe


PAYRE serge <> spayre@centralp.fr> > wrote:
hi,


I want to use pccard_launch utility to start automaticaly devb-eide
server
to manage an ATA card flash memory. To do this, I write on a shell the
following command :

pccard-launch -v ‘0x400,devb-eide eide ioport=0x200,irq=5’ &

When I insert my pcmcia card devb-eide is launched
When I remove my card devb-eide is already started (I can see it with ps
utility)
When I insert my card for the second time, devb-eide is out : I see
nothing
with ps utilty and my shell is out too


When I start the server on a shell all is good. I can read and write file
onto pcmcia card


could you help me


thank,