slay -P 16 devi-hirun

I have one of those systems that exhibits radical mouse movements
unless the priority of devi-hirun is raised. Of course I would like
to figure out an easy way to automate the raising of this priority.
For starters, I used pidin to find devi-hirun, then ran renice,
and that seemed to work, but it also seemed a bit difficult to
automate. Then I remembered the slay -P option. Unfortunately
slay -P16 devi-hirun returns a message something like:

setprio(33184,16):

I don’t remember the actual text of the message, but
it definitely didn’t work. The pid listed is the correct one,
I’m root, renice can do it. Any idea what’s going wrong?

And of course perhaps the more straightforward question should
be: what is the best way to raise the priority of devi-hirun?
Can I somewhere locate the commandline that invokes it in the
first place and add a “nice” prefix?

This is quite strange. On my 6.1 Patch A box slay -P 18 devi-hirun works
fine.

“Norton Allen” <allen@huarp.harvard.edu> wrote in message
news:3BB32902.748983F6@huarp.harvard.edu

I have one of those systems that exhibits radical mouse movements
unless the priority of devi-hirun is raised. Of course I would like
to figure out an easy way to automate the raising of this priority.
For starters, I used pidin to find devi-hirun, then ran renice,
and that seemed to work, but it also seemed a bit difficult to
automate. Then I remembered the slay -P option. Unfortunately
slay -P16 devi-hirun returns a message something like:

setprio(33184,16): <failed

I don’t remember the actual text of the message, but
it definitely didn’t work. The pid listed is the correct one,
I’m root, renice can do it. Any idea what’s going wrong?

And of course perhaps the more straightforward question should
be: what is the best way to raise the priority of devi-hirun?
Can I somewhere locate the commandline that invokes it in the
first place and add a “nice” prefix?

Hi Norton,
I think you’ve read a thread “Photon session tuning” at this newsgroup. I’ve reported this problem
but I have no response yet. As a work around I’ve added the next lines to the /usr/bin/ph:
pid=slay -p devi-hirun
renice -16 -p $pid
I’m novice in unix, maybe this is not elegant, but it works.
And I still want to know why “slay -P 25 devi-hirun” does not work.

Best regards,
Eduard.
P.S. == “No such process”. Is not it curious?

Norton Allen <allen@huarp.harvard.edu> wrote in article <3BB32902.748983F6@huarp.harvard.edu>…

I have one of those systems that exhibits radical mouse movements
unless the priority of devi-hirun is raised. Of course I would like
to figure out an easy way to automate the raising of this priority.
For starters, I used pidin to find devi-hirun, then ran renice,
and that seemed to work, but it also seemed a bit difficult to
automate. Then I remembered the slay -P option. Unfortunately
slay -P16 devi-hirun returns a message something like:

setprio(33184,16): <failed

I don’t remember the actual text of the message, but
it definitely didn’t work. The pid listed is the correct one,
I’m root, renice can do it. Any idea what’s going wrong?

And of course perhaps the more straightforward question should
be: what is the best way to raise the priority of devi-hirun?
Can I somewhere locate the commandline that invokes it in the
first place and add a “nice” prefix?

“Alex Chapiro” <achapiro@qnx.com> wrote in message
news:9ovbal$b7o$1@nntp.qnx.com

This is quite strange. On my 6.1 Patch A box slay -P 18 devi-hirun works
fine.

You have to be root to do that, could that be the problem

“Norton Allen” <> allen@huarp.harvard.edu> > wrote in message
news:> 3BB32902.748983F6@huarp.harvard.edu> …
I have one of those systems that exhibits radical mouse movements
unless the priority of devi-hirun is raised. Of course I would like
to figure out an easy way to automate the raising of this priority.
For starters, I used pidin to find devi-hirun, then ran renice,
and that seemed to work, but it also seemed a bit difficult to
automate. Then I remembered the slay -P option. Unfortunately
slay -P16 devi-hirun returns a message something like:

setprio(33184,16): <failed

I don’t remember the actual text of the message, but
it definitely didn’t work. The pid listed is the correct one,
I’m root, renice can do it. Any idea what’s going wrong?

And of course perhaps the more straightforward question should
be: what is the best way to raise the priority of devi-hirun?
Can I somewhere locate the commandline that invokes it in the
first place and add a “nice” prefix?

Mario Charest <mcharest@clipzinformatic.com> wrote in article <9ovbnr$gat$1@inn.qnx.com>…

“Alex Chapiro” <> achapiro@qnx.com> > wrote in message
news:9ovbal$b7o$> 1@nntp.qnx.com> …
This is quite strange. On my 6.1 Patch A box slay -P 18 devi-hirun works
fine.


You have to be root to do that, could that be the problem

Mario, even root can not do “slay -P 16 devi-hirun”. This action causes the message
setprio(, 16) : No such process

:wink:
Try it on qnxrtp 6.1.0

Alex, where is patch A?


Eduard.


“Norton Allen” <> allen@huarp.harvard.edu> > wrote in message
news:> 3BB32902.748983F6@huarp.harvard.edu> …
I have one of those systems that exhibits radical mouse movements
unless the priority of devi-hirun is raised. Of course I would like
to figure out an easy way to automate the raising of this priority.
For starters, I used pidin to find devi-hirun, then ran renice,
and that seemed to work, but it also seemed a bit difficult to
automate. Then I remembered the slay -P option. Unfortunately
slay -P16 devi-hirun returns a message something like:

setprio(33184,16): <failed

I don’t remember the actual text of the message, but
it definitely didn’t work. The pid listed is the correct one,
I’m root, renice can do it. Any idea what’s going wrong?

And of course perhaps the more straightforward question should
be: what is the best way to raise the priority of devi-hirun?
Can I somewhere locate the commandline that invokes it in the
first place and add a “nice” prefix?

\

“ed1k” <ed1k@yahoo.com> wrote in message
news:01c1475f$f8a4ce20$396fa8c0@ED1K…

Mario Charest <> mcharest@clipzinformatic.com> > wrote in article
9ovbnr$gat$> 1@inn.qnx.com> >…

“Alex Chapiro” <> achapiro@qnx.com> > wrote in message
news:9ovbal$b7o$> 1@nntp.qnx.com> …
This is quite strange. On my 6.1 Patch A box slay -P 18 devi-hirun
works
fine.


You have to be root to do that, could that be the problem

Mario, even root can not do “slay -P 16 devi-hirun”. This action causes
the message
setprio(, 16) : No such process

:wink:
Try it on qnxrtp 6.1.0

Wow that’s odd as it works fine for me (and I’m using 6.1.0)

Alex, where is patch A?


Eduard.



“Norton Allen” <> allen@huarp.harvard.edu> > wrote in message
news:> 3BB32902.748983F6@huarp.harvard.edu> …
I have one of those systems that exhibits radical mouse movements
unless the priority of devi-hirun is raised. Of course I would like
to figure out an easy way to automate the raising of this priority.
For starters, I used pidin to find devi-hirun, then ran renice,
and that seemed to work, but it also seemed a bit difficult to
automate. Then I remembered the slay -P option. Unfortunately
slay -P16 devi-hirun returns a message something like:

setprio(33184,16): <failed

I don’t remember the actual text of the message, but
it definitely didn’t work. The pid listed is the correct one,
I’m root, renice can do it. Any idea what’s going wrong?

And of course perhaps the more straightforward question should
be: what is the best way to raise the priority of devi-hirun?
Can I somewhere locate the commandline that invokes it in the
first place and add a “nice” prefix?

\

Mario Charest <mcharest@clipzinformatic.com> wrote in article <9ovevj$id5$1@inn.qnx.com>…

Wow that’s odd as it works fine for me (and I’m using 6.1.0)

Mario,
Very strange… I’m using QNX RTP 6.1GA (upgrade from 6.0C)
I really can not do “slay -P 20 devi-hirun”, but I can do “slay -P 10 io-graphics”, for example. Of
course, as a root… And I have yet another odd thing, maybe you help me. I don’t see the first
thread of devi-hirun. Is it normal?

pidin | grep devi-hirun

335900 2 devi-hirun 10o …
335900 3 devi-hirun 10o …
335900 4 devi-hirun 12o …

Thank you.
Eduard.

Mario,
Are you using standard devi-hirun which is comed with installation? I have devi-hirun from
developers.qnx.com but I did not try it yet. I’ve read readme file and I’d no found it’s useful for
me as I have standard serial mouse (I’ve tried ALL serial mouses which I have at home and at office
:wink:)… Oh, sorry, the main my problem is unwanted chaotic mouse events, and strange behaviour of
“slay” is an another yet trouble.

Thank you,
Best regards.

“ed1k” <ed1k@yahoo.com> wrote in message
news:01c14769$5805d540$396fa8c0@ED1K…

Mario Charest <> mcharest@clipzinformatic.com> > wrote in article
9ovevj$id5$> 1@inn.qnx.com> >…


Wow that’s odd as it works fine for me (and I’m using 6.1.0)


Mario,
Very strange… I’m using QNX RTP 6.1GA (upgrade from 6.0C)
I really can not do “slay -P 20 devi-hirun”, but I can do “slay -P 10
io-graphics”, for example. Of
course, as a root… And I have yet another odd thing, maybe you help me.
I don’t see the first
thread of devi-hirun. Is it normal?

pidin | grep devi-hirun

335900 2 devi-hirun 10o …
335900 3 devi-hirun 10o …
335900 4 devi-hirun 12o …

I can hear the theme of “twilight zone” in the distance… That explains
why you cannot slay.
The first thread is the one that get affected by the slay -P command. Now
why is the
first thread not showing up, i have not clue.



Thank you.
Eduard.

“ed1k” <ed1k@yahoo.com> wrote in message
news:01c1476f$79113f80$396fa8c0@ED1K…

Mario,
Are you using standard devi-hirun which is comed with installation?

Yes, I’ve tried both 6.1 and 6.1A beta.

I have devi-hirun from
developers.qnx.com but I did not try it yet. I’ve read readme file and I’d
no found it’s useful for
me as I have standard serial mouse (I’ve tried ALL serial mouses which I
have at home and at office
:wink:> )… Oh, sorry, the main my problem is unwanted chaotic mouse events,
and strange behaviour of
“slay” is an another yet trouble.

The slay problem is probably a side effect ;-(

Thank you,
Best regards.

This is a good case. What I found that this is a slay problem. The message
you see on screen (about setprio) just reflect the fact, that setprio fails.
But in case you are using serial mouse (opposit to PS2 mouse case) thread 1
does not exist. But setprio change priority only for thread #1. I’ll talk
tomorrow to guys who are responsible for slay.

“Norton Allen” <allen@huarp.harvard.edu> wrote in message
news:3BB32902.748983F6@huarp.harvard.edu

I have one of those systems that exhibits radical mouse movements
unless the priority of devi-hirun is raised. Of course I would like
to figure out an easy way to automate the raising of this priority.
For starters, I used pidin to find devi-hirun, then ran renice,
and that seemed to work, but it also seemed a bit difficult to
automate. Then I remembered the slay -P option. Unfortunately
slay -P16 devi-hirun returns a message something like:

setprio(33184,16): <failed

I don’t remember the actual text of the message, but
it definitely didn’t work. The pid listed is the correct one,
I’m root, renice can do it. Any idea what’s going wrong?

And of course perhaps the more straightforward question should
be: what is the best way to raise the priority of devi-hirun?
Can I somewhere locate the commandline that invokes it in the
first place and add a “nice” prefix?

Hi Alex,

Alex Chapiro <achapiro@qnx.com> wrote in article <9p00hf$nma$1@nntp.qnx.com>…

This is a good case. What I found that this is a slay problem. The message
you see on screen (about setprio) just reflect the fact, that setprio fails.
But in case you are using serial mouse (opposit to PS2 mouse case) thread 1
does not exist. But setprio change priority only for thread #1. I’ll talk
tomorrow to guys who are responsible for slay.

Thank you for detailed explanation. I hope it will useful to make slay better still :wink:

Best regards,
Eduard.

Thank you one and all, and I’m sorry I haven’t been around
for most of the follow-up. Yes it is bizarre, which is why
I posted it in the first place.