lpd grief; what am I doing wrong? (Size limits)

I have the following /etc/printcap file:

rp|lp:rm=10.0.0.100:mx=0:sh:hl:sd=/var/spool/lpd:lf=/var/log/lpd-errs:

I start “lpd” with no command-line options.

Yet, when I submit a file via “lpr -Prp”, if the file is greater than
1M in size, it complains about the lack of space. I have 700 MB free
on the /var/spool/lpd device, and I thought that the “mx=0” should
now allow the size to be unbounded. Files that are less than 1 M
print just fine…

What did I screw up? :slight_smile:

(On another note, “lpr” always wants to print the header page, even though
I think I’ve correctly told it not to in the /etc/printcap file…)

Thanks,
-RK

Robert Krten, PARSE Software Devices +1 613 599 8316.
Realtime Systems Architecture, Consulting and Training at www.parse.com
Email my initials at parse dot com.

It should be “mx#0” not “mx=0”.

Re-read the printcap documentation :slight_smile:

This is a very common error.

Rob Rutherford

<nospam93@parse.com> wrote in message news:9vdevd$sjl$1@inn.qnx.com

I have the following /etc/printcap file:

rp|lp:rm=10.0.0.100:mx=0:sh:hl:sd=/var/spool/lpd:lf=/var/log/lpd-errs:

I start “lpd” with no command-line options.

Yet, when I submit a file via “lpr -Prp”, if the file is greater than
1M in size, it complains about the lack of space. I have 700 MB free
on the /var/spool/lpd device, and I thought that the “mx=0” should
now allow the size to be unbounded. Files that are less than 1 M
print just fine…

What did I screw up? > :slight_smile:

(On another note, “lpr” always wants to print the header page, even though
I think I’ve correctly told it not to in the /etc/printcap file…)

Thanks,
-RK

Robert Krten, PARSE Software Devices +1 613 599 8316.
Realtime Systems Architecture, Consulting and Training at > www.parse.com
Email my initials at parse dot com.

Robert Rutherford <ruzz@nospamplease.ruzz.com> wrote:

It should be “mx#0” not “mx=0”.

Re-read the printcap documentation > :slight_smile:

Duh. Yup, there it is in black and white.

This is a very common error.

Thanks Rob, that fixed it! Any idea on the header page?

-RK

Rob Rutherford

nospam93@parse.com> > wrote in message news:9vdevd$sjl$> 1@inn.qnx.com> …
I have the following /etc/printcap file:

rp|lp:rm=10.0.0.100:mx=0:sh:hl:sd=/var/spool/lpd:lf=/var/log/lpd-errs:

I start “lpd” with no command-line options.

Yet, when I submit a file via “lpr -Prp”, if the file is greater than
1M in size, it complains about the lack of space. I have 700 MB free
on the /var/spool/lpd device, and I thought that the “mx=0” should
now allow the size to be unbounded. Files that are less than 1 M
print just fine…

What did I screw up? > :slight_smile:

(On another note, “lpr” always wants to print the header page, even though
I think I’ve correctly told it not to in the /etc/printcap file…)

Thanks,
-RK

Robert Krten, PARSE Software Devices +1 613 599 8316.
Realtime Systems Architecture, Consulting and Training at > www.parse.com
Email my initials at parse dot com.


Robert Krten, PARSE Software Devices +1 613 599 8316.
Realtime Systems Architecture, Consulting and Training at www.parse.com
Email my initials at parse dot com.

Sorry, don’t know about the header page, other than to suggest removing the
hl.

Due to general lpd lameness, I often end up specifying lp=/dev/null and
doing all the real work in the so-called input filter (if=…).

Robert

<nospam93@parse.com> wrote in message news:9vl0lf$18l$1@inn.qnx.com

Robert Rutherford <> ruzz@nospamplease.ruzz.com> > wrote:
It should be “mx#0” not “mx=0”.

Re-read the printcap documentation > :slight_smile:

Duh. Yup, there it is in black and white.

This is a very common error.

Thanks Rob, that fixed it! Any idea on the header page?

-RK

Rob Rutherford

nospam93@parse.com> > wrote in message news:9vdevd$sjl$> 1@inn.qnx.com> …
I have the following /etc/printcap file:

rp|lp:rm=10.0.0.100:mx=0:sh:hl:sd=/var/spool/lpd:lf=/var/log/lpd-errs:

I start “lpd” with no command-line options.

Yet, when I submit a file via “lpr -Prp”, if the file is greater than
1M in size, it complains about the lack of space. I have 700 MB free
on the /var/spool/lpd device, and I thought that the “mx=0” should
now allow the size to be unbounded. Files that are less than 1 M
print just fine…

What did I screw up? > :slight_smile:

(On another note, “lpr” always wants to print the header page, even
though
I think I’ve correctly told it not to in the /etc/printcap file…)

Thanks,
-RK

Robert Krten, PARSE Software Devices +1 613 599 8316.
Realtime Systems Architecture, Consulting and Training at > www.parse.com
Email my initials at parse dot com.


\

Robert Krten, PARSE Software Devices +1 613 599 8316.
Realtime Systems Architecture, Consulting and Training at > www.parse.com
Email my initials at parse dot com.

nospam93@parse.com wrote:

Robert Rutherford <> ruzz@nospamplease.ruzz.com> > wrote:
It should be “mx#0” not “mx=0”.

Re-read the printcap documentation > :slight_smile:

Duh. Yup, there it is in black and white.

This is a very common error.

Thanks Rob, that fixed it! Any idea on the header page?

-RK

Rob Rutherford

nospam93@parse.com> > wrote in message news:9vdevd$sjl$> 1@inn.qnx.com> …
I have the following /etc/printcap file:

rp|lp:rm=10.0.0.100:mx=0:sh:hl:sd=/var/spool/lpd:lf=/var/log/lpd-errs:

I start “lpd” with no command-line options.

Yet, when I submit a file via “lpr -Prp”, if the file is greater than
1M in size, it complains about the lack of space. I have 700 MB free
on the /var/spool/lpd device, and I thought that the “mx=0” should
now allow the size to be unbounded. Files that are less than 1 M
print just fine…

What did I screw up? > :slight_smile:

(On another note, “lpr” always wants to print the header page, even though
I think I’ve correctly told it not to in the /etc/printcap file…)

We have the same problem with QNX4; It seems the “-h” option to lpr works better.

Thanks,
-RK

Robert Krten, PARSE Software Devices +1 613 599 8316.
Realtime Systems Architecture, Consulting and Training at > www.parse.com
Email my initials at parse dot com.


\

Robert Krten, PARSE Software Devices +1 613 599 8316.
Realtime Systems Architecture, Consulting and Training at > www.parse.com
Email my initials at parse dot com.