using blk parameters

Hello,

Starting the devb-eide driver with the blk ro parameter takes no effect.
I’m starting the driver in my image like this:

devb-eide blk automount=hd1t77:/:qnx4 ro noatime delwri=0 eide
dma,ioport=0x1f0,irq14 eide dma,ioport=0x170,irq15

But after booting, I still can write to disk.

Any ideas ?

“christian” <chs@am3.com> wrote in message news:aabi65$c6s$1@inn.qnx.com

Hello,

Starting the devb-eide driver with the blk ro parameter takes no effect.
I’m starting the driver in my image like this:

devb-eide blk automount=hd1t77:/:qnx4 ro noatime delwri=0 eide
dma,ioport=0x1f0,irq14 eide dma,ioport=0x170,irq15

Separate blk options with commas, not with spaces, e.g. blk
ro,noatime,delwri=0
(your eide options are correctly stated )

Pavol Kycina

Hello Pavol,
thanks for your help. I’ve tried to sepperate with commas, but still doesn’t
take any effect on read/write
behaviour.

Christian



Pavol Kycina <kycina@microstep-hdo.sk> schrieb in im Newsbeitrag:
3cc95750$1@asrpx.mshdo

“christian” <> chs@am3.com> > wrote in message
news:aabi65$c6s$> 1@inn.qnx.com> …
Hello,

Starting the devb-eide driver with the blk ro parameter takes no effect.
I’m starting the driver in my image like this:

devb-eide blk automount=hd1t77:/:qnx4 ro noatime delwri=0 eide
dma,ioport=0x1f0,irq14 eide dma,ioport=0x170,irq15

Separate blk options with commas, not with spaces, e.g. blk
ro,noatime,delwri=0
(your eide options are correctly stated )

Pavol Kycina