telnetd problem on embedded system


I’m trying to get telnet to work on my target that has my own boot file - I seem to be having the same problems other people have had in other posts, but I can’t find a distinct solution anywhere.

Telnet outputs:

connected to
Escape character is ‘^]’.
Connection closed by foreign host.

I seem to have everything included from the help files.

If I run inetd with debug options, here is what I get when I try to login:

FREE: telnet proto=tcp6, wait:max=09.4, user:group=root. builtin=0server bun/telnetd policy=
accept, ctrl 3
159753 reaped, status 0x100

FYI: I have a symbolic link from /bin/login to /bin/sh

Also, it seems weird but inetd changes the name of my node to EA0c5a7 which has no significance to me - maybe the two problems are related


devc-pty is not running?

the host name changine is probably done by qnet, as it don’t like “localhost”.

In my boot file I have:

devc-pty -n 10 &

I also have netmanager running with a net.cfg file that has a hostname, domanin and route.


where are you running this telnet command from ? is it from momentics or from shell?
And can you ping your target with that IP address ?
Furthermore, can you connect using ftp?
It could be something related to the users, like your target has user with no password or root with no password.


Looks like you were right, the problem was with users - I had login as a symbolic link to sh, which the 6.3 help docs says is possible, but I had not users - I was just running sh from the build file.

In the end I added both login (the real version) and passwd and set up a root user. This worked, although I don’t know if it was because it was missing the files needed by passwd or the real version of login.


Good to know that it’s working and I feel good to have helped Waterloo~ cuz I am from Univeristy of Toronto :slight_smile:
ERTW forever~

I have a different question related to telnetd on an embedded system.

I’ve got telnetd running on an embedded system. Right now I’m connected to the system via a serial port console. I’m trying to free up the serial port for other tasks, and need to be able to telnet into the system to configure it, etc.

I can telnet into the embedded system (telnet into the embedded system from the same system) and it works fine.

If I try and telnet in from a separate system (Windows box or stand alone QNX box), the screen clears but I never get prompted for username/password. I try and type the username anyway, and the screen appears locked or non-responsive. From the serial port console I can see that telnetd and login are running (ps). If I kill either of these processes, the screen unfreezes and goes back to the host OS (i.e. aborts telnet session).

Any ideas on what I am missing to enable telnet/login from an external system?