Remote re-boot

Does anyone know how to remotely re-boot a PC over QNet? The shutdown -n
option is not implemented,and using on e.g

on -d -n remotenode shutdown

only succeeds in slaying a few processes on the remote node before it hangs.
This was no problem in QNX4…

Jim

Hello Jim,

I have tested the “on” utility on both a QNX6.1a system and a QNX6.2 system
with no problems. What release are you using?

Regards,
Dave B.


“Jim Douglas” <jim@dramatec.co.uk> wrote in message
news:agkimg$n2h$1@inn.qnx.com

Does anyone know how to remotely re-boot a PC over QNet? The shutdown -n
option is not implemented,and using on e.g

on -d -n remotenode shutdown

only succeeds in slaying a few processes on the remote node before it
hangs.
This was no problem in QNX4…

Jim

I am using 6.2. I know that ‘on’ works OK, but on in combination with
shutdown does not work for me.Could you give me the exact command line that
you have used to re-boot a remote node?

Jim

“Dave” <dboltz11@rogers.com> wrote in message
news:agl5t4$bsh$1@nntp.qnx.com

Hello Jim,

I have tested the “on” utility on both a QNX6.1a system and a QNX6.2
system
with no problems. What release are you using?

Regards,
Dave B.


“Jim Douglas” <> jim@dramatec.co.uk> > wrote in message
news:agkimg$n2h$> 1@inn.qnx.com> …
Does anyone know how to remotely re-boot a PC over QNet? The shutdown -n
option is not implemented,and using on e.g

on -d -n remotenode shutdown

only succeeds in slaying a few processes on the remote node before it
hangs.
This was no problem in QNX4…

Jim

\

That’s strange. Running 6.2NC, I made a script that ran:

on -d -nremotenode shutdown -S reboot

for many nodes and they all rebooted (though I had to space them by
sleeps sometimes). These nodes only run QNX, so your setup might differ.

-Matt

In article <agkimg$n2h$1@inn.qnx.com>,
“Jim Douglas” <jim@dramatec.co.uk> wrote:

Does anyone know how to remotely re-boot a PC over QNet? The shutdown -n
option is not implemented,and using on e.g

on -d -n remotenode shutdown

only succeeds in slaying a few processes on the remote node before it hangs.
This was no problem in QNX4…

Jim