can't FTP file from /dev/shmem

Greetings,

I FTP-ed to QNX-6.2.0 box as ‘root’, changed to /dev/shmem, and
‘put’ file there. That part worked fine. However, when I FTP-ed
to this box again, again as ‘root’, and tried to ‘get’ this file
from /dev/shmem, I got error message “not a plain file”. The file
is actually there, I can do whatever I pleased with it,
but I can’t ‘get’ it through FTP. Is it supposed to be this way,
or I run into a bug ?

Thanks in advance,
Andray

Run ftpd with the “-A” command line arg. From the online docs:

-A
Allow clients to access non-regular files such as named special
files under /dev/shmem. Use this option only when access to
such files are necessary – this may allow mallicious users to
open any path on the system (for which they have appropriate
file permissions) with undesired results.

Andray Kaganovsky <andrayk@deletefutureway.com> wrote:

Greetings,

I FTP-ed to QNX-6.2.0 box as ‘root’, changed to /dev/shmem, and
‘put’ file there. That part worked fine. However, when I FTP-ed
to this box again, again as ‘root’, and tried to ‘get’ this file
from /dev/shmem, I got error message “not a plain file”. The file
is actually there, I can do whatever I pleased with it,
but I can’t ‘get’ it through FTP. Is it supposed to be this way,
or I run into a bug ?

Thanks in advance,
Andray


Kirk Russell Bridlewood Software Testers Guild