Fsys.ide/ata QNX4.25G warm boot

I have to change a broken hard disk to a machine with qnx 4.25G version with an IDE Flash Disk (64Mb TDK type).
The systems seems to work well, but I have a big problem.
After the system is on (i.e. after the launch of Fsys.ide) the auto-detect area of the pc-like shows a different ide parameter rack. As a consequence I am not able to make a warm boot (i.e. I have a request to insert a floppy at reboot).
Of course I tried to ignore bios data, to force the proper rack data (cyl,heads and so on), but there is no way. After the launch of Fsys.ide (and its brothers Fsys.ata and Fsys.eide), I got the same result: no warm reboot. By the way the re-read rack data show me exactly the half memory (32MB) of the Ide Flash disk.
I have no problem if I use qnx 4.25A or if I use a different flash ide (64MB Hitachi type).
Please, does any one knows why is it happening?
Thank you

It seems lots of people have problems with Flash drive disk geometry and QNX.

Check the following discussion, though for QNX 6, it should give you some ideas:


Thank you for your reply.
Now, maybe, I better understand the problem, even if I do not see any solution.
In fact my problem arise even before using fdisk at all.
I am using IDE flash disk (no USB) with a really old system (AMIBIOS 08/08/93 - SBC386 Board processor ALI M6117C) with PQI IDE DiskOnModule 64mB.
After booting from floppy, I launch any of Fsys.ide/Fsys.ata with all sort of parameters (No LBA, forcing the config and so on. Of course changing with the proper setting from the bios, i.e. if there is no LBA I set this into the bios) and in any case I got the same locking problem, with the automatic detection reducing the cyl from 500 to 244 and consequently the Mb to 32.
In my opinion, there is a probable faulty or buggy thing in the Fsys.ide/ata driver of 4.25G (but I recognize that I could have some form of incompatibility between the cpu board and the IDE flash disk).
By the way if I use a Win95 boot disk I got no problem.
Thank you

Sorry, I changed the subject on my previous reply …

Just a correction.
The error is the same for any 4.25 version (in effect Fsys.ide/ata is unchanged, dated 1998). What gives me the right result is version 4.22 (Fsys.ata dated Dec. 1994).