SMB sharing between QNX and OSX

Hi all! I’m a QNX newbie. I have a SOHO LAN with many macs, a couple of windows machines and a linux box as network backup server.

I just wanted to try QNX, so I downloaded and installed the trial QNX Momentics 6.3.0, then I tried to share a folder using samba share, just as on linux (debian). I tried using security=share, just to see if it would run, and it runs…with windows. Infact all windows machines can connect, explore and write to the samba share…but not the OSX macs!!! Connecting from OSX gives me an error after asking the password (leaving it blank, like when connecting to a not protected windows share).
I tried also using security=user and setting up like on debian, but it’s the same.

Does anybody know how to solve this? When I was on debian I just configured smb.conf (with security=user, in that case), added users with smbpasswd, and it worked without problems both with win and mac.

Maybe is smb version 2.7 not compatible? There’s a most recent version?

Thanks for help…if more info is needed, just ask :slight_smile:

p.s. is samba sharing between OSX and QNX a good choice?

Not too up on Samba and OSX, but as I understand it OSX is a complete operating system, and should therefore have NFS. So using NFS shares may be a work around.

Yes it may be, but I read in an other post that NFS is included only in QNX commercial version so…it would stop working after 30 days evaluation???

If not, there’s an howto on setting up nfs shares? I never used it.