telnet Fails on 6.2 S.E. System

After installing Momentics and the patch on my embedded system, I was unable
to telnet to the computer. Below is the result of a telnet attempt on the
local console, but similar results were obtained from attempts on other
hosts.

telnet 0

Trying 0.0.0.0…
Connected to 0.
Escape character is ‘^]’.
in.telnetd: illegal option – Q
Usage: telnetd [-debug] [-D (options|report|exercise|netdata|ptydata)]
[-h] [-n]
[-u utmp_hostname_length] [-U] [port]
Connection closed by foreign host.

Sure enough, when I look in the /etc/inetd.conf file, there is a line that
includes in.telnetd -Q. Although it isn’t in the telnetd documentation, that
looks like a valid option from other posts I’ve read. Does anyone have a
guess about what my real problem is? Possibly missing a needed file or
library?

The following is from a post in comp.os.qnx, referring to the inetd.conf
file:

telnet stream tcp nowait root /bin/telnetd in.telnetd -Q

The -Q switch is essential since beta6 does not support settings
via termdef (so don’t use the inetd.conf that comes with QNX4).

Thanks,
David Kuechenmeister

Are you running inetd?

pidin | grep inetd


Jens


“David Kuechenmeister” <david.kuechenmeister@viasat.com> wrote in message
news:b8u7rd$dce$1@inn.qnx.com

After installing Momentics and the patch on my embedded system, I was
unable
to telnet to the computer. Below is the result of a telnet attempt on the
local console, but similar results were obtained from attempts on other
hosts.

telnet 0

Trying 0.0.0.0…
Connected to 0.
Escape character is ‘^]’.
in.telnetd: illegal option – Q
Usage: telnetd [-debug] [-D (options|report|exercise|netdata|ptydata)]
[-h] [-n]
[-u utmp_hostname_length] [-U] [port]
Connection closed by foreign host.

Sure enough, when I look in the /etc/inetd.conf file, there is a line that
includes in.telnetd -Q. Although it isn’t in the telnetd documentation,
that
looks like a valid option from other posts I’ve read. Does anyone have a
guess about what my real problem is? Possibly missing a needed file or
library?

The following is from a post in comp.os.qnx, referring to the inetd.conf
file:

telnet stream tcp nowait root /bin/telnetd in.telnetd -Q

The -Q switch is essential since beta6 does not support settings
via termdef (so don’t use the inetd.conf that comes with QNX4).

Thanks,
David Kuechenmeister

Yes. I think the problem is an old inetd.conf file. Here is the version
info.

@(#)inetd.conf 1.23 90/01/03 SMI

Although, this should be the file from the 6.2 distribution, maybe someone
can confirm that there is a newer version.

Thanks,
David

“Jens H Jorgensen” <jhj@remove-nospam-videk.com> wrote in message
news:b8u9q5$fe4$1@inn.qnx.com

Are you running inetd?

pidin | grep inetd


Jens


“David Kuechenmeister” <> david.kuechenmeister@viasat.com> > wrote in message
news:b8u7rd$dce$> 1@inn.qnx.com> …
After installing Momentics and the patch on my embedded system, I was
unable
to telnet to the computer. Below is the result of a telnet attempt on
the
local console, but similar results were obtained from attempts on other
hosts.

telnet 0

Trying 0.0.0.0…
Connected to 0.
Escape character is ‘^]’.
in.telnetd: illegal option – Q
Usage: telnetd [-debug] [-D (options|report|exercise|netdata|ptydata)]
[-h] [-n]
[-u utmp_hostname_length] [-U] [port]
Connection closed by foreign host.

Sure enough, when I look in the /etc/inetd.conf file, there is a line
that
includes in.telnetd -Q. Although it isn’t in the telnetd documentation,
that
looks like a valid option from other posts I’ve read. Does anyone have a
guess about what my real problem is? Possibly missing a needed file or
library?

The following is from a post in comp.os.qnx, referring to the inetd.conf
file:

telnet stream tcp nowait root /bin/telnetd in.telnetd -Q

The -Q switch is essential since beta6 does not support settings
via termdef (so don’t use the inetd.conf that comes with QNX4).

Thanks,
David Kuechenmeister

\

On Fri, 2 May 2003 14:04:27 -0400, “David Kuechenmeister” <david.kuechenmeister@viasat.com> wrote:

Yes. I think the problem is an old inetd.conf file. Here is the version
info.

@(#)inetd.conf 1.23 90/01/03 SMI

Although, this should be the file from the 6.2 distribution, maybe someone
can confirm that there is a newer version.

It doesn’t look like -Q is a valid option, does it?
I also went thoguth a bit of a struggle getting telnet setup on an
embedded system and finally succeeded, and there is no -Q in my inetd.conf.
The post you saw is quite old… Beta6 could be 6.0’s beta?

David Kuechenmeister <david.kuechenmeister@viasat.com> wrote:

The following is from a post in comp.os.qnx, referring to the inetd.conf
file:

telnet stream tcp nowait root /bin/telnetd in.telnetd -Q

The -Q switch is essential since beta6 does not support settings
via termdef (so don’t use the inetd.conf that comes with QNX4).

-Q used to be a valid option to telnetd, but isn’t anymore.

It would have been nice if our telnetd had, maybe, silently accepted
and ignored that option for historical reasons, but it doesn’t.

-David

QNX Training Services
http://www.qnx.com/support/training/
Please followup in this newsgroup if you have further questions.

In article <b8ugns$d7d$2@nntp.qnx.com>, dagibbs@qnx.com says…

-Q used to be a valid option to telnetd, but isn’t anymore.

It would have been nice if our telnetd had, maybe, silently accepted
and ignored that option for historical reasons, but it doesn’t.

No. It would be nice to give a message about invalid option and ignoring it, and then continue to
work for historical reason. Silently accepting of invalid options is a BAD THING, IMHO.

Eduard.

-David

David Kuechenmeister <david.kuechenmeister@viasat.com> wrote:

Yes. I think the problem is an old inetd.conf file. Here is the version
info.

@(#)inetd.conf 1.23 90/01/03 SMI

Anybody know what SMI stands for?
Is it Sun Microsystems Inc?
I’ve seen tons of those SMI headers on my Sun systems.