ok so i am ok with all of you calling me a retard. that being said: my first time logging in (6.3) i think the user was called Superuser ? i then ‘edit’ that user changed the name to my name, password to my password, and created a second general user.

there was a bunch of groups and i thought i only wanted 4 or 5 so i deleted them and made my own groups. the shells i did not touch since i wasnt sure yet what they were for.

Right now i can log into the two users i made, however i cannot get root access. i cannot run the installer because it asks for the root password. ive tried, both users passwords, blank, root, password and superuser (with caps and without). I dont know if its somehting i did, but i cannot get root access. the FAQ says the root user is ‘root’ with a blank password. Ive tried this and it wont log on, and nothing is accepted when the installer asks for the root pass.
Did i do something wrong, or am i being dumb? Thanks for your help


Superuser == root (It is sort of the “real” name for root. so it is not good to rename it)

So you should “reset” all the settings you’ve done by rewriting the file /etc/passwd as follows:

root::0:0:Superuser:/root:/bin/sh bin:x:1:1:Binaries Commands and Source:/bin: daemon:x:2:2:System Services:/daemon: mail:x:8:40:User Mail:/var/spool/mail: news:x:9:50:Network News:/var/spool/news: uucp:x:12:60:Network News:/var/spool/news: ftp:x:14:80:FTP User:/home/ftp: nobody:x:99:99:Nobody:/:
(the ‘x’ in the second place indicates a password so leave it away for root an set the password later using the tools)
As you need to be root to change this file it is probably necessary to boot from the CD.

I’am not sure about this now, but I think the groups are there for a certain purpose. so you better change /etc/group too:

root:x:0:root bin:x:1:root,bin daemon:x:2:daemon sys:x:3:root,bin,adm adm:x:4:root,adm,daemon tty:x:5:root mail:x:40:mail news:x:50:news uucp:x:60:uucp ftp:x:80:ftp guest:x:90: nobody:x:99:

Perhaps you can just copy these files from the CD instead of rewriting them…

ok now, i boot from the CD,… how do i knwo if i am looking at the files i am using to boot with, or the files on my hard drive. i open passwd and group as u said and both are exactly as shown above,… it doesnt even show the two users i can log on with,… i suspect i am somehow looking at the mounted file? HELP

If you boot from CD, your local hard disk will be automatically mounted in the /fs directory. Your QNX partition is probably mounted as /fs/hd0-qnx4 so the files you are looking for will be in /fs/hd0-qnx4/etc You can copy the default /etc/passwd, /etc/group in here and remove the “shadow” file.

Once you fix everything and boot back into Hard disk, login as Superuser (root) with blank passwd, and then you can reset your passwd by “passwd root”.

You might find it useful to read the Managing User Accounts chapter of the Neutrino User’s Guide.