mount nfs on QNX server

Mount command not working

mount -t -nfs :/home /mnt/home

This command simply comes out without any error,but the mount is not visible at /mnt/home.

take out the - before nfs in your mount command, so it looks like this:

mount -t nfs :/home /mnt/home

btw, QNX should have printed an error in your case since there was no argument to the -t option. I consider this a QNX bug.