Widget Flicker problem

Hi there.

I’ll really need help with this. .

I have tested to get the doublebuffering to work by using a PtOSContainer.
Then to test it i’ve added 2 PtClock’s with a HUGE digital font.
The first one i made as a child of the PtOSContainer. the second one is not
, and it’s placed below
the PtOSContainer area.

Now here’s the problem:

In Application Builder , the Top clock is totally flicker free…
The clock below is flickering alot…

I do a Generate,make and then run the application…

Everything flickers …

Is there something that need to be set ? what’m missing ?

// Mikael Rickan

What kind of hardware are you using?

How big is “HUGE”?

Rod

Previously, Mikael Rickan wrote in qdn.public.qnxrtp.photon:

Hi there.

I’ll really need help with this. .

I have tested to get the doublebuffering to work by using a PtOSContainer.
Then to test it i’ve added 2 PtClock’s with a HUGE digital font.
The first one i made as a child of the PtOSContainer. the second one is not
, and it’s placed below
the PtOSContainer area.

Now here’s the problem:

In Application Builder , the Top clock is totally flicker free…
The clock below is flickering alot…

I do a Generate,make and then run the application…

Everything flickers …

Is there something that need to be set ? what’m missing ?

// Mikael Rickan

I have a ATI Rage graphics card,
and i use 800x600 resolution, so the clock is about 700x250 in size (just to
test… )
But the main problem is that i cant se any different when using the
PtOSContianer…

Rodney Dowdall <rdowdall@qnx.com> wrote in message
news:Voyager.010123101523.602133B@rdowdall…

What kind of hardware are you using?

How big is “HUGE”?

Rod

Previously, Mikael Rickan wrote in qdn.public.qnxrtp.photon:
Hi there.

I’ll really need help with this. .

I have tested to get the doublebuffering to work by using a
PtOSContainer.
Then to test it i’ve added 2 PtClock’s with a HUGE digital font.
The first one i made as a child of the PtOSContainer. the second one is
not
, and it’s placed below
the PtOSContainer area.

Now here’s the problem:

In Application Builder , the Top clock is totally flicker free…
The clock below is flickering alot…

I do a Generate,make and then run the application…

Everything flickers …

Is there something that need to be set ? what’m missing ?

// Mikael Rickan
\

I couldn’t reproduce the flicker.
I made a test case similiar to the one you described, and put it here:
http://www.qnx.com/~rich/flicker_test.gz
Let us know if it flickers for you as well.

-Rich


Mikael Rickan <mikael.rickan@semcon.se> wrote:

I have a ATI Rage graphics card,
and i use 800x600 resolution, so the clock is about 700x250 in size (just to
test… )
But the main problem is that i cant se any different when using the
PtOSContianer…

Rodney Dowdall <> rdowdall@qnx.com> > wrote in message
news:Voyager.010123101523.602133B@rdowdall…
What kind of hardware are you using?

How big is “HUGE”?

Rod

Previously, Mikael Rickan wrote in qdn.public.qnxrtp.photon:
Hi there.

I’ll really need help with this. .

I have tested to get the doublebuffering to work by using a
PtOSContainer.
Then to test it i’ve added 2 PtClock’s with a HUGE digital font.
The first one i made as a child of the PtOSContainer. the second one is
not
, and it’s placed below
the PtOSContainer area.

Now here’s the problem:

In Application Builder , the Top clock is totally flicker free…
The clock below is flickering alot…

I do a Generate,make and then run the application…

Everything flickers …

Is there something that need to be set ? what’m missing ?

// Mikael Rickan
\

Hi Richard

Your app works fine.
Could the problem be because i have an PtBkgd (with image) behind the clock?
In that case , how do I reduce the flickering ?

My widget structure is like this:
-PtWindow

  • PtOSContainer
    -PtBkgd
    -PtLabel

And the label get’s updated atleast onece a sec…

Richard Potter <rich@qnx.com> wrote in message
news:94kbb0$2ge$1@nntp.qnx.com

I couldn’t reproduce the flicker.
I made a test case similiar to the one you described, and put it here:
http://www.qnx.com/~rich/flicker_test.gz
Let us know if it flickers for you as well.

-Rich