Problem mounting cdrom

I have inherited a development system from a previous engineer.
It’s running QNX 6.1.
Supposedly, the cdrom drive is automounted on /fs/cd0. But it isn’t.

When I try to access /fs/cd0, I get “no such device or address”.

I have also tried creating a different directory and doing a
‘mount -t cd /dev/cd0 /tmp/cdrom’ for instance. Then I get the
message: “can’t mount , possible reason: device busy”.

Can anyone suggest how to get around this? I need to be able to
read cd’s on this system, and so far, I can’t.


post the output from “df”.

btw, I remember there were some issues with CD in QNX 6.1. eg: CD drive has to be on the IDE master or standalone. You can put it on the secondary IDE channel.

Good suggestion. Here is the df output:
/dev/fd0 0 0 0 100%
/dev/cd0 0 0 0 100% (/fs/cd0/)
/dev/hd0t79 15004647 5431035 9573612 37% /
/dev/hd0t78 17141355 4227 17137128 1% /fs/hd0-qnx4-2/
/dev/hd0 60032449 60032449 0 100%

I noticed that it shows the drive mounted on /fs/cd0, just like I was told.
Armed with that information, I tried some other CDs. I got it to read
one, just fine. Then why was I getting “no such device or address”
when I tried to read this other one? Tried it in a Windows machine,
STILL wouldn’t read. Hmmm. Looked carefully at the CD - I don’t
think it ever got written!

Problem solved. Thanks for the help.