6.3.0 SP1 service pack installation fails?

I installed 6.3.0 eval yesterday, but can’t install the SP1.sh file as distributed from the QNX web site (downloaded thrice to make sure it’s not damaged):

The script creates a backup file, back’s up IDE help files and then complains about some file not being in gzip format. Anyone who knows what’s the problem here?


Is this on self hosted x86, or Windows/Linux/Solaris cross-dev environment?

Self hosted x86 (my good old Piii PC)…
I reinstalled after posting this question, because I changes some things before I tried to install SP1.
Clean installation gives the same error however

Are you sure you are not running out of disk space or something?

Pretty sure, it’s a 12 GB disk…
After the backups are created, the script tries to unzip something (probably the SP updates for various
files) through stdin, and complains that ‘stdin is not in gzip format’). Then it reports this is a fatal error
and restores the just created backups…

Fixed the problem - I think it was a memory issue. I figured I’d give it a try after booting without Photon,
which indeed allowed me to install the SP.