SH7780 - QNX - J9

I have some problems and need help!

At the moment I work in a project in which we try to install qnx on SH7780 and later we want to run java applications using j9 on it.
But my problems begin with installing qnx on the board. I have a BSP for SH4a board, but when I try to build it, I get an image without drivers for the flashmemory. I get the error
“Flash filesystem headers/libraries not present on system”.

I thougt the BSP delivers me everything I need to build the image. Am I wrong, do I have to write own drivers for the flashmemory or do I have forgotten something.

Please help me, because I do not know anybody who has worked with QNX before.

Thanks for your answers.

Hello Tobias

Your right. You need some more stuff to make your flash file system work. Just contact your QNX-support to get a Fash TDK for your specific board.
Hopefully it will work then.

How far are you, running j9?
I’ve got the following problem trying to run j9 on my QNX 6.3. I have written a simple HelloWorld for my Board. I tryed to start it with:

 j9 -jcl:foun10 -cp /j9/lib/jclFoundation10/ HelloWorld

But I get the following error message:
codeZIPS0000 unable to open j9zlib22 (Library cannot be found)
Exception in thread “main” java.lang.NoClassDefFoundError: HelloWorld[/code]
Do you or anybody else have a solution?
I’m sure to have installed all necessary files. Also the lib is available under /j9/bin. Are any platform conflicts possible? Any ideas?

Thanks for your promt answers.
Bye Huette

Hello Huette

Thx. I contacted my QNX-support and I will get the needed Flash TDK on Monday.

Try to use -Xbootclasspath:/j9/lib/jclFoundation10/ instead of -cp /j9/lib/jclFoundation10/
that should help. I have read it in a tutorial when I tried to start the SMF on my Board.

Have a nice Weekend,

I’m not aware of any 7780 BSP from QNX. So if you have one, it is probably alpha and can have some problems.

I work with “QNX Momentics 6.3.0 Renesas EDOSK 7780 BSP 1.0.0” and “QNX Momentics SP2 Beta”.

I can’t find this BSP on myQNX. It must be an unofficial pre-release then. You probably are a good QNX customer then. :wink:
Do you have a QNX support plan? Then you can phone or e-mail the QNX support people. They are quite helpful.