blue border terror

how do I prevent the blue border from appearing
when a PtMultiText widget gets focus?


k.

Turn focus render off on the widget (in PhAB or in code). This can be found
in the “Flags” resource.

Unfortunately, there is a small problem with AppBuilder’s palette file - it
thinks that focus render is turned off when you first create a multitext.
All you need to do it turn focus render on, then turn it off.

-William Bull
bbull @ qnx.com

“kvack” <eh@nospam.ty> wrote in message
news:Voyager.001014011200.1900574A@localhost.localdomain

how do I prevent the blue border from appearing
when a PtMultiText widget gets focus?

.
k.

Previously, William Bull wrote in qdn.public.qnxrtp.devtools:

Turn focus render off on the widget (in PhAB or in code). This can be found
in the “Flags” resource.

Unfortunately, there is a small problem with AppBuilder’s palette file - it
thinks that focus render is turned off when you first create a multitext.
All you need to do it turn focus render on, then turn it off.

-William Bull
bbull @ qnx.com

“kvack” <> eh@nospam.ty> > wrote in message
news:> Voyager.001014011200.1900574A@localhost.localdomain> …



how do I prevent the blue border from appearing
when a PtMultiText widget gets focus?

.
k.


I had to set Pt_CLIP_HIGHLIGHT …with Pt_FOCUS_RENDER off…

If Pt_CLIP etc. isn’t set, the border gets blue in any case :slight_smile: