Makefile use in IDE

I am runnning the Eclipse-IDE and I want to use my one makefile.
Without using the IDE we are running a script that looks for certain files
on the PC. If these are present a Variable is exported. We are using these
variable as compiler switch in our code.
Right now I did not find a way tu use something similar with the IDE.
Anybody an idea?
Thanks

Frank

Frank <frank.sczech@soudronic.com> wrote:

I am runnning the Eclipse-IDE and I want to use my one makefile.
Without using the IDE we are running a script that looks for certain files
on the PC. If these are present a Variable is exported. We are using these
variable as compiler switch in our code.
Right now I did not find a way tu use something similar with the IDE.
Anybody an idea?

Don’t use a “QNX C application project” type of project.

When you create a “Standard Make C/C++ project” type of project, it
doesn’t setup any default makefiles or anything.

You can have it run a script, write your own makefile, anything you
want.

By default it will run make…right a makefile with appropriate targets.

But, you can tell it to not use the default builder in the wizard, and
browse to find an executable, and have it run that…this could be your
discovery & build script.

Or it could be your makefile.

-David

QNX Training Services
http://www.qnx.com/support/training/
Please followup in this newsgroup if you have further questions.

David Gibbs wrote:

Don’t use a “QNX C application project” type of project.

When you create a “Standard Make C/C++ project” type of project, it
doesn’t setup any default makefiles or anything.

You can have it run a script, write your own makefile, anything you
want.

By default it will run make…right a makefile with appropriate targets.

But, you can tell it to not use the default builder in the wizard, and
browse to find an executable, and have it run that…this could be your
discovery & build script.

Or it could be your makefile.

-David

QNX Training Services
http://www.qnx.com/support/training/
Please followup in this newsgroup if you have further questions.

Hello David

I tried to do that like you described it. I set the build command under
Properties->C/C++ Project → Build Settings
top my make-script.
An error occurs with the folowing message:

! CBuilder.build_error
(Exec error)

What am I doing wrong?
Just a remark: I am runing the IDE on a QNX6.2 host.

Regards Frank

Frank <frank.sczech@soudronic.com> wrote:

Hello David

I tried to do that like you described it. I set the build command under
Properties->C/C++ Project → Build Settings
top my make-script.
An error occurs with the folowing message:

! CBuilder.build_error
(Exec error)

What am I doing wrong?

Sorry for the delay getting back to you.

I created a script:

#!/bin/sh
echo “test build script”
exit 0

And did a chmod ugo+x on it.

It ran fine, I saw the “test build script” in my build window.

I then did a chmod ugo-x on it, and tried to build again…

and got the exec error that you posted.

So:
– make sure your build program/script actually has execute perms
– make sure, if it is a script, it starts with #!/bin/sh

-David

QNX Training Services
http://www.qnx.com/support/training/
Please followup in this newsgroup if you have further questions.

David Gibbs <dagibbs@qnx.com> wrote:

Frank <> frank.sczech@soudronic.com> > wrote:
Hello David

I tried to do that like you described it. I set the build command under
Properties->C/C++ Project → Build Settings
top my make-script.
An error occurs with the folowing message:

! CBuilder.build_error
(Exec error)

What am I doing wrong?

Sorry for the delay getting back to you.

I created a script:

#!/bin/sh
echo “test build script”
exit 0

And did a chmod ugo+x on it.

It ran fine, I saw the “test build script” in my build window.

I then did a chmod ugo-x on it, and tried to build again…

and got the exec error that you posted.

Also, leaving it ugo+x, but removing the #!/bin/sh from the
script also resulted in the exec error.

-David

So:
– make sure your build program/script actually has execute perms
– make sure, if it is a script, it starts with #!/bin/sh

-David

QNX Training Services
http://www.qnx.com/support/training/
Please followup in this newsgroup if you have further questions.


QNX Training Services
http://www.qnx.com/support/training/
Please followup in this newsgroup if you have further questions.

David Gibbs wrote:

David Gibbs <> dagibbs@qnx.com> > wrote:
Frank <> frank.sczech@soudronic.com> > wrote:
Hello David

I tried to do that like you described it. I set the build command under
Properties->C/C++ Project → Build Settings
top my make-script.
An error occurs with the folowing message:

! CBuilder.build_error
(Exec error)

What am I doing wrong?

Sorry for the delay getting back to you.

I created a script:

#!/bin/sh
echo “test build script”
exit 0

And did a chmod ugo+x on it.

It ran fine, I saw the “test build script” in my build window.

I then did a chmod ugo-x on it, and tried to build again…

and got the exec error that you posted.

Also, leaving it ugo+x, but removing the #!/bin/sh from the
script also resulted in the exec error.

-David

So:
– make sure your build program/script actually has execute perms
– make sure, if it is a script, it starts with #!/bin/sh

-David

QNX Training Services
http://www.qnx.com/support/training/
Please followup in this newsgroup if you have further questions.


QNX Training Services
http://www.qnx.com/support/training/
Please followup in this newsgroup if you have further questions.

Thanks David, now it runs perfect!
It was the “#!/bin/sh” entry that was missing.
Thanks again
Frank

Frank <frank.sczech@soudronic.com> wrote:

David Gibbs wrote:

Thanks David, now it runs perfect!

Great.

It was the “#!/bin/sh” entry that was missing.
Thanks again

You’re welcome. Glad to help.

-David

QNX Training Services
http://www.qnx.com/support/training/
Please followup in this newsgroup if you have further questions.