dinit -m on QNX RTP 6.1

I have tried, to replace the boot message “Hit Esc for .altboot” of an floppy at QNX RTP 6.1 .

I have tried several options, but i can’t change the message.
E.g. dinit -f test.ifs -m “test.” /dev/fd0

If I change the message via the spatch utility, it works.

In the online help of dinit stand, that the message can be up to 30 characters.
But if I change more than 20 chars (the original message is 20 chars long), the
floppy don’t boot.

‘dinit -m’ doesn’t work in QNX RTP 6.1. Try latest version of QNX or use spatch :slight_smile: Your message can’t be longer than 20 chars and should be trailing 0x00 at the end of string. Probably, 30 chars long message and -m option were intended in 6.1 but not realized.

Hello ed1k,

Try latest version of QNX or use spatch

First I have used QNX 6.2.1 NC.
Then I recognized, that I can’t use the following things in the newest version:

  • mkifs
  • flash filesystem

Then I downdated to QNX RTP 6.1.

Why they have removed all these good stuff from the actually NC version ?

That are very interesting parts of QNX, I remember the “Incredible 1.44 MB Floppy Disk” with
QNX, Photon, Voyager …

keep on remembering !

i used to hand this ‘incredible’ floppy to my friends and now the entire gang experiences sleepless nights while digging deeper and deeper into qnx.

such a great stuff. i am talking seriously now !!