OT: Qnx-6.2.1 and Qemu-0.8.0

I have an old CD of QNX-6.2.1 and I was able to install it
under qemu-0.8.0 but had no luck with the networking part.
Qemu uses NE2000 compatible RTL-8029 card emulation and there
is no driver for this in Qnx.

Any ideas of locating a driver for this card?

-ishwar

I’m pretty sure there is a NE2000 driver in there devn-ne2000.so.

It does not detect the card during install or later reboots. So, How do I load it?

-ishwar

NE2000 is an isa card, and QNX doesn’t auto detect ISA devices.

mount -T io-net devn-ne2000 should do it.

I tried

mount -T io-net devn-ne2000

and I see the error:

mount: Can’t mount / (type io-net)
mount: Possible reason: No such device or address

-ishwar

Just tried

io-net -d ne2000 verbose=4

  1. how to find what happened?
  2. what does the ether-interface show up as in
    ifconfig -a output?

-ishwar

I have tried this also without any luck did you get it to work?

Chris,

If you look in the helpviewer under ‘ISA’ you’ll find some info on getting ISA cards to work.

The doc’s more or less say you’ll need to specify the IRQ, DMA mode etc when starting the driver. To see how to set those options, look at ‘io-net’ in the helpviewer and then click on ‘devn-ne2000.so’ link.

Tim

A number of the NE2000 ISA cards did not have visible dip switches or jumpers. The cards did however come with a DOS program that allowed configuration. I mention this because you might need to configure a card before you get it working.

You can let qemu to simulate a RTL 8139 PCI card with option:

-net nic,model=rtl8139

That should make your life easier.