Problems with a TBeach Santa Cruz on QNX RTOS 6.2.1

This has been ongoing for a while now but I’m finally looking for some help here. QNX does not find my audio device and I have no idea why. It’s listed under supported hardware. The device shows up under pci -v. Here’s the output of that.

Class = Multimedia (Audio)
Vendor ID = 1013h, Cirrus Logic
Device ID = 6003h, CS4614/22/24 CrystalClear SoundFusion PCI Audio Accel
PCI index = 0h
Class Codes = 040100h
Revision ID = 1h
Bus number = 0
Device number = 10
Function num = 0
Status Reg = 410h
Command Reg = 6h
Header type = 0h Single-function
BIST = 0h Build-in-self-test not supported
Latency Timer = 20h
Cache Line Size= 0h
PCI Mem Address = db100000h 32bit length 4096 enabled
PCI Mem Address = db000000h 32bit length 1048576 enabled
Subsystem Vendor ID = 5053h
Subsystem ID = 3357h
Max Lat = 24ns
Min Gnt = 4ns
PCI Int Pin = INT A
Interrupt line = 10
Capabilities Pointer = 40h
Capability ID = 1h
Capabilities = 622h - 0h

Does anyone have any suggestions for why my card may not be working? I already tried pulling out everything else except the video card and sound card (in case it was an IRQ issue) but it still doesn’t detect.

Is there any manual process I can go through to force detection?

If we don’t provide a driver you will have to look to see if this chipset is supported by the 3 non-QSS drivers out there (igor and mike wrote them). I suspect you will be out of luck.