why i can't write the file on floppy disk

I am a beginner,I have made a boot floppy disk and also I want to start a ftp server,but after boot from floppy disk,I can’t write the file on floppy disk so i can’t change the password of anyone(when i run rm ,it return READONLY-FILESYSTEM),how should i do?please help me.

How did you create the floppy, what boot image did you use. What are you trying to rm. Can you post your boot image.

I use the example bios.build in qnx6.3 as the skeleton,after boot i run inetd,the client ftp can login as user ftp,but can’t list any file(can upload ) , Using user root ,it can’t login. i use passwd to change password ,passwd exited status=1(an error)
here is my project.

part02 is missing (an maybe more)









part12(the last one)

Why I can’t change password ?I run “passwd” it return 1 , the files /etc/passwd ,/etc/shadow,/etc/.pwlock and other is in floppy disk ,should it be more free space on floppy?

Well that`s a pain, can you make it into one file…

I dont think the file .pwlock should exists. Its only present where passwd is running. It could be that passwd terminates because that file is present (thinking that another passwd is running)

The net is too slow ,i spend much time to upload
I am a beginner ,so i meet much trouble during studying QNX.
I have made a boot floppy disk,but I can’t write to the disk except to the memory dir.(dev/shmem)
I can’t change any user’s password (“passwd” return 1),should I install the os to harddisk?how should i do?