QNX 4.25 VMWare / Xgeneric / Hydra.ms / Shared memory

Hi, I have a problem getting the old X11 (using Xgeneric) to run under VMware with QNX 4.25
I know there is Xfree86 around for QNX4, but we need the old stuff Metro X for an existing app.
I got everything running but the Xgeneric crashes with a segv (“got signal 11”) . It crashes before it can display “Map - fd:1 *mem etc…”, so my assumption is that the problem is around shared memory. I have seen the Hydra.ms modeswitcher and Xgeneric both open /dev/shmem/Physical as RW.
Funny thing is: Photon 1.13 is running using same modeswitcher Hydra.ms using Pg.flat driver.
I must note however, that the default arguments for Hydra.ms did not work, I had to add -r (switch processor real mode) to make it, otherwise even Photon would not show the Screen (1024x768x8).
My version of Xgeneric is Jul 14, 1997, Size: 961443
Has someone managed to get Metro-X with QNX4 runinng with VMWare? If its running with another server in any mode > 640x480 should be fine.
I tried all the servers in all resolutions but none works, seems VMWare does not emulate any existing VGA hardware (except VESA modes).

Never tried Xgeneric with VMware. I used XFree86 with QNX 4 and VMWare without a problem. BTW, I never had an issue running Metro X existing app with XFree86 server. Just make sure you using the tcp connection rather than the unix connection.

Thanks for your suggestions. I will probably give it another try some with XFree86.