Problem with gf_dev_attach

I’m developing a simple OpenGL ES app on QNX, but I’m having problem with gf_dev_attach. io-graphics is running, yet gf_dev_attach fails.

Here is what I do:
int main()
{ /* Omitting details */
gf_dev_t gf_dev;
gf_dev_info_t info;

if (gf_dev_attach(&gf_dev, NULL, &info) != GF_ERR_OK) {
printf(“gf_dev_attach() error\n”);
return -1;


Can anyone tell me what could have gone wrong?

Thanks very much in advance,

I don’t know a thing about OpenGL, but the value of errno might give you a clue as to what is going on.

Thanks mario.

I had always assumed that the system was fully configured to run graphics (since I was able to see some graphical programs running). It seems that for OpenGL ES to work on this target, I need to set up GF and the io-display process. This was not done. The other programs didn’t have this requirement.



I have the same Problem with io-display. How did you fix it?

It would be nice if you could give me a hint!



To get GF running, you need to first setup io-display, which needs to be run before your application can run.

See %QNX_TARGET%\usr\help\product\gf\dev_guide\monitor.html for more information.

It turns out that the QNX Advanced Graphics TDK will update your hardware driver, so that you can run io-display, GF and your application. However, currently the TDK only supports a few hardware, such as “Fujitsu CoralP”. My hardware is not yet supported, so I didn’t get any further…

Hope this helps!

I tried to set up io-display with this display.conf
device {
display {

by calling io-display.
The process is displayed as running, but if I call “gf_dev_attach(&gdev,GF_DEVICE_INDEX(0),&gdev_info);”
it always returns the GF_ERR_IODISPLAY error.
I use a geforce 2 which is supported by the driver so far.

You wrote that your hardware was not supported… what happened?


I have installed the tdk on my windows host and copied the io-display of the downloadable patch to my target /sbin/ … is this ok?

Ok, if I just call io-display without any arguments it looks ok, but if I call it
io-display -dvid=0x10de,did=0x152
“Function not supported” is written.

Does this mean that my card is not supported?

That quite possible, there are only a very very few support card (most are not mainstream)

I have tried several options… the only driver which seams to be working is the coral.
Do you know how it is possible to work without GF? Is there a way?

I tried with eglGetDisplay(EGL_DEFAULT_DISPLAY);
but also the same problem

The only supported driver for the Advanced Graphics TDK is the Fujitsu Coral P/PA. The normal Photon drivers will not work. The TDK is new and driver mods had to be made for this release which makes existing 6.30 Photon drivers incompatible.


Ok, thanks. I tried it with the old graphics kit, now it is working, but without hardware acceleration neither 2D nor 3D.