Elan SC300 and QNX6.1 problems (reboots)

Hi everyone,

I’m a newbie to the QNX scene, so please forgive my ignorance…

I’m trying to get a QNX6.1 system up and running on a PC104 card with the
ElanSC300 processor. I’m still in the beginning stages of learning how to
create OS image files, etc. and have been experimenting with getting the
system up an running by attaching a normal EIDE hard disk to the PC104
card’s IDE connector.
I created a minimal image file with just the console driver, and a couple
other items, including a “hello, world” program. The system comes up, and
apparently sees the boot partition and then tries to start the system from
that partition, as I see the normal “hit esc for .altboot”. After a series
of “…”, the system simply reboots. I thought that I may have really
messed up my os-image, so I played around with various combinations, none of
which worked and most of which ended with the same results, or something
Out of desperation, I stole my colleague’s elan 5xx card to compare, and
lo-and behold, it worked! The system boots just fine and does what I
expect it to do.
After looking around the QNX site, I found a knowledge base note about the
SC400 rebooting with QNX4.2x systems. I’m not sure, but this seems to be
suspiciously similar to the problem I’m having. Is this a known problem,
and if so, is there a fix? The sample program dealing with the
keyboard/BIOS issue provided along with the knowledge base article won’t
work under QNX6. Is there an updated version of this program?

Any help received will be greatly appreciated.