USB drivers

I am using a USB keyboard and mouse. I start the drivers in the rc.local
file as follows:

io-usb -duhci &
devu-mouse &
debu-kbd &

Now, if I put
devi-hirun kbd -R fd -d/dev/usbkbd0 msoft fd -d/dev/usbmouse0 &

in the .profile, it doesn’t start this driver.However, if i open a shell and
give the above command, it works. I’d like to run this command at startup.
Where so I put it ?

Thanks
Shashank

By the time your .profile runs the input driver is already running (if you
boot into photon).
The ph script will call inputtrap to startup the input driver. inputtrap
will look for a trapfile to see how to start the driver, if it does not
exist it will use the standard PS/2 ports. You should create an input
trapfile will the command options to use USB. See inputtrap in the utility
docs for details.

Regards,

Joe

“Shashank” <sbalijepalli@precitech.com> wrote in message
news:d0phct$i0i$1@inn.qnx.com

I am using a USB keyboard and mouse. I start the drivers in the rc.local
file as follows:

io-usb -duhci &
devu-mouse &
debu-kbd &

Now, if I put
devi-hirun kbd -R fd -d/dev/usbkbd0 msoft fd -d/dev/usbmouse0 &

in the .profile, it doesn’t start this driver.However, if i open a shell
and
give the above command, it works. I’d like to run this command at startup.
Where so I put it ?

Thanks
Shashank

\