I’m giving another try at the IDE.

Self Hosted:

I’ve started a makefile project. I then build the project, all is good all
the object files are created, as I hoped they would. There a a few warning
I want to get rid of, i click on the task item, then click again, then
double click, nothing. Hum I’m expecting the c file to be loade with the
cursor on the right line, but nothing. What is perculiar about this project
tree is the source files are NOT in the same directory as the makefile, in
fact they are scatter in different directory. So I though to myself, oh I
can just add the c files to the project. After 2 minutes I gave up cause I
couldn’t figure out how to do it or if it was all possible. Is it just me
or the Eclipse IDE is highly unintuive? The question is how should this

Windows host:

I tried the same thing. The files are sitting on a network driver on the QNX
box (same files as above). I build the project but get this:

No such file or directory

I openned a bash shell (didnt it use to be an icon from the start menu to access the shell). Then did "vi /cygdrive/z/home/mcharest/LinuxVer_X64_Only/X64/makerules.x64.depend.qnx6: No such file or directory" and it worked. So the file is accessible. I tried running make from the shell, same result. Make cant find the file
for whatever reason. I am at a lost.

By the way, the restriction to not have spaces in the directory name where
QNX6.3 installs on the windows host is very Precambrian if you ask me ( I
know I know you didn`t ask)