Compilation problem

Hi, I have compiled Apache2.2.0 with ./configure --prefix=/usr/local/apache --enable-so

Now I try to compile php4.4.2 with ./configure --prefix=usr/local/php --with-mysql=/usr/local/mysql --with-apxs2=/usr/local/apache/bin/apxs --with-zlib --with-gd

When I run make install get:

*** Warning: inter-library dependencies are not known to be supported.
*** All declared inter-library dependencies are being dropped.

*** Warning: libtool could not satisfy all declared inter-library
*** dependencies of module libphp4. Therefore, libtool will create
*** a static module, that should work as long as the dlopening
*** application is linked with the -dlopen flag. is not created, any idea?

I know this will not be of any help, but I ran into exactly the same roadblock.

And how you solved it?
I need php4 as an Apache module, but don’t know how fix the “interlibrary dependencies”!


I haven’t solved it. I noticed that there was a dicussion on this website on how to do this. It involved downloading some executables, but they were older versions of Apache. My strategy right now is to bring up a Linux server, since I’m not tied to QNX for this use.