Problems on io-audio setup

Hi guys! :wink:

I downloaded the QNX 6.3.0 and sadly I can’t setup the audio device…

In the boot process the system show me these errors…

mount: Can’t mount / (type io-audio)
mount: Possible reason: No such file or directory
mount: Can’t mount / (type io-media)
mount: Possible reason: No such file or directory

And reading the documentation of the QNX I tried to setup the io-audio but give me again the same error.

Do I need to create special device files on /dev? Because I can’t see the io-audio…

I can see only io-graphics and io-net.

If was required, how can I create them, because on a Linux system we have the MAKEDEV shell scripot

I’m trying to set up a Sound Blaster 32 PnP ISA card on a Soyo K7VTA-B Motherboard,

The PNP OS Installed option on my Bios is OFF (disabled)

Thanx and my best regards!! :wink: :stuck_out_tongue:

you will be find io-audio in /sbin (type: [color=brown]use io-audio for more information about it), so scan your pci bus with [color=brown]pci -v for some hardware information

It’s not PCI but ISA, so that won’t help you. I’m having the same problem here, except my chip is an uncommon onboard Crystal CS4236, and I’m running QNX 6.2.1.

The problem is that QNX doesn’t seem to have drivers for your ISA card. Or it can’t detect it or something like that. I’m wondering if it could be possible to do some raw mount on the ISA card, if you know the ioports and IRQ? … pic&t=6015

How to find the information you need - like the memory location? … pic&t=5860
That helped me find the following information (wasn’t in the output file but in the terminal output):Enumerator data: 'D880676 bus=isapnp devid=CSC0010 ioport=0534 ioport1=0388 iopo rt2=0220 irq=5 dma=1 dma1=0' Unable to find definition for device: bus=isapnp devid=CSC0010 ioport=0534 ioport1=0388 ioport2=0220 irq=5 dma=1 dma1=0You should be able to do that too for your soundblaster. But the next step I don’t know.

I just got my card working. This is what I did.
1. Slay all io-audio instances (using the System Information utility of QNX 6.2.1 in Launch-Utilities)
2. Execute the following command: io-audio -dsb Apparently my chip is SB compatible, because that driver works fine. Maybe you should try this too. Good luck!