PCMCIA problems

I’m trying to get a PCMCIA network card to work with my QNX4.25 setup. I
took the pccard driver and its accompanying utilities off a fresh
install of 4.25G and put them on my target machine (it’s got 4.25B), and
I’m having some issues getting everything working. Here’s what’s happening:

Hardware info:

  • PCMCIA chipset: TI 1510

  • PCMCIA card: 3Com 10/100 LAN CardBus Model 3CCFE575CT

  • Using the card’s DOS setup utility, the card’s base address is set to
    3400h and IRQ to 5 (apparently that’s the only free IRQ I’ve got)

  • When I run ‘pccard’ it starts up successfully, but it doesn’t detect
    any cards. Running ‘pc-pin’ shows one socket listed as ‘Empty’ even when
    the card is inserted.

  • If I instead run the ‘Pcmcia.generic’ driver, it detects a card in the
    socket but lists it as type ‘Memory’ with no IRQ or base address.

  • Now here’s the weird part: If I run the Pcmcia.generic driver, and
    then run pccard, pccard detects the network card. However, I don’t think
    the card is being set up correctly. Here’s the output of pc-pin:

Sock Func Type Flags PID Base Size IRQ
1 0 Network C—I-±-----SAW None 0x1000 256 9
0x8121000 4096
1 Empty ----MF---------- None

If I try to specify a different base address or IRQ to pccard, nothing
is different and the pc-pin output is still the same.

Just in case the card was actually working, I tried running the
Net.ether1000 driver, but that resulted in a hard system lock. Any help
you could provide would be awesome!