QNX 4.23 and rsh issues

I’m new to QNX and I’m having a problem when trying to use rsh. I have one QNX machine (app2) and one Solaris machine (srv01). I can rsh from app2 to srv01 but I can’t from srv01 to app2. Both app2 and srv01 have a user mario account.

I get permission denied. When I run inetd –d on app2 I get the following:
someone wants shell
accept, ctrl 3, err 35
18324 execl /usr/ucb/rshd
18324 reaped

Note that I get the same permission denied message and output from inetd when trying rsh as root. rlogin works for app2 –> srv01

On the QNX (app2) I have:
-srv01 listed in the /etc/hosts file
-shell, exec and login uncommented in /etc/inetd.conf

  • checked to make sure /etc/services has an entry for shell
  • tried a single “+â€

I doubt there is much community memory left on details of TCP/IP from the 4.23 era. Your err 35 comes from inetd. I doubt the QNX inetd is very different from anyone elses, so you could look around for inetd source code. It might be an errno value, so /usr/include/errno.h might be a place to start.

Just so you know, there was a completely new TCP/IP released for QNX 4, but I doubt it will run on anything less than 4.25.

Thanks. I will check on the errno. The tcprt is version 4.25.