ruby under QNX 6.3.2

Just a tip in case anyone else is crazy enough to want to get some of this newer web stuff running on QNX. If you want to get a current version of ruby work, before you start, get the latest version of zlib and install it. Make sure you replace /usr/ with the the that zlib puts in /usr/local/lib. This will save much time in the future.

Are you crazy, er, brave enough to try running Ruby on QNX 6.3.x?
If so, please share experience or point to same posted elsewhere.


Here’s my recollection from a couple of months ago. Aside from the comment I made getting the latest zlib, the configuration and build of ruby went without much effort. I also downloaded and got the rails framework working. Again, it just seemed to work as advertised the first time. I know that mod_ruby exists as a loadable addition to Apache, but I haven’ tried it yet.

I don’t think “crazy” is at all out of line. ;-).

Hi maschoen,
I’m also willing to use Ruby on QNX 6.3.x. I’m currently running 6.3.0.
Ruby 1.8.5 compiled without any effort.
The ‘make install’ fails though: when trying to install bin/ri, it throws:
./instruby.rb:174:in ‘truncate’ : File too large - /usr/local/bin/ri (Errno::EFBIG).

Note that ‘configure’ reports: ‘checking for _LARGE_FILES value needed for large files… no’.
But this didn’t bother the build.

Did you face this?
Also, why do you recommend updating libz?

Glad to see we’re a few in the sandbox!

Thanks for your help,


Off the top of my head, I don't know which version of ruby I'm running.   I recall that the make and install went without a hitch.   If you want, I'll check further.


It would be kind of you to provide your working setup, if handy.
I’ll try 1.8.4 in the meantime and post the results here.

It is version 1.8.5. I’ve archived it and placed at anonymous ftp at, name ruby-1.8.5.pax.F. In theory, you should just have to de-archive this to a QNX 6.3 system, and run “make install”.

Thanks Mitchel, I will certainly give this a try.
Here are my results building ruby 1.8.4, 1.8.5 and 1.8.6:
QNX630: They all build succesfully but they all fail at some point during make install, complaining about ‘File too large…’. See previous post in this thread.
QNX621B: They all build succesfully and seems to install succesfully too. The install process throws exceptions at the beginning, but completes somehow. ruby --version reports the right version. No further tests were performed yet.

QNX-DEV /home/martin/home630/ruby-1.8.5# make install ./miniruby ./instruby.rb --dest-dir="" --make="make" --mflags="" --make-flags="" --mantype="man" unknown symbol: rb_eRuntimeError unknown symbol: rb_eArgError unknown symbol: rb_check_safe_obj unknown symbol: rb_ary_new unknown symbol: rb_define_module unknown symbol: rb_int2inum unknown symbol: rb_tainted_str_new2 unknown symbol: rb_define_module_function unknown symbol: rb_scan_args unknown symbol: rb_global_variable unknown symbol: rb_struct_define unknown symbol: rb_num2long unknown symbol: rb_ensure unknown symbol: rb_sys_fail unknown symbol: rb_string_value unknown symbol: rb_secure unknown symbol: rb_ary_push unknown symbol: rb_block_given_p unknown symbol: rb_raise unknown symbol: rb_struct_new unknown symbol: rb_yield

Unfortunately, I got the exact same error when installing from your archive.
I’m still working on it and I’ll post my progress.