Can't access floppy on qnx4.25

I have installed qnx 4.25 on a newer P7 cpu (855 chipset) which is a new VME board design. It boots from the floppy, runs XP. Linux & DOS with floppy access from these OS’s. However, I can’t seem to access the floppy after qnx boots (ver 4.25). If I run Fsys.floppy it DOES NOT create /dev/fd0. The floppy controllers is at 0x3f0h and int 6. I have tried to explicitly specify these params when I invoke Fsys.floppy. I’ve tried turning on diagnostics for Fsys.floppy and it doesn’t generate any obvious errors. I initially had PNP turned off in the bios when I installed and have since then turned it back on.

Any ideas?
Brent Bartson

Yes PnP should be turn on, but I’ve never heard of having any effect on floppy. What type of floppy is it? I remember that things like LS-120 would actually be handled by Fsys.eide.

Well, I’ve tried three different drives. All 3.5in 1.44MB, and like I said they all work with DOS/XP/Linux. I think they are Mitsumi’s but I’d have to dig into the hardware to be more specific. The floppy controller is an SIO device (SMSC SCH3114) off the southbridge chipset (6300).

I’ve just installed 6.3 on the same hardware and the floppy works under 6.3. However, I need to run 4.25 for awhile because I’m trying to get a vme driver that was written here years ago running under 4.25 first so I can test out some interrupts before porting the whole driver to 6.3… hence the weird request.

If I can’t get the floppy working under 4.25 do you know if USB flash drives will work under 4.25?

Yes USB works, you need to get the USB package from QSS though. (doesn’t come with it)