Network card installation on QNX6

I installing QNX6 - RF6 in a new PC. But I can’t set the 3COM Network card.
If I do :

pci -v

Class = Network (Ethernet)
Vendor ID = 10b7h, 3COM corp
Device ID = 9055H, 3C905B-TX Fast Etherlink 10/100 PCI TX NIC
PCI index = 0h
PCI IO Address = 1100H enabled
PCI Mem address = 60000100H enabled
PCI Expansion ROM = fffe0000h disabled
PCI Int Pin = INT A
Interrup Line = 11
CPU Interrupt = BH

The problem is when I open NETWORK on QNX6-Neutrino configure. That window only have Connection and Network . “Device” is missing. Then I can not set the IP address for that network card.
How should I do to set the IP ? :frowning:


If you do an ‘ifconfig -a’ from the command prompt what do you see?

You should see an lo0 and and en0 if your card was recognized. If you only see an lo0 then it was not recognized.

Assuming it was recognized you can manually edit the config file when your logged in as root. It’s in /etc and it’s called net.cfg

For example mine looks like this:

nto network config file v1.2

version v1.2

hostname US002QNX427

type ethernet
mode manual

If you want to use DHCP then you change the mode manual to mode dhcp and don’t provide the last 2 lines.


Sorry for the intrusion … but I have the same identical problem with a US Robotics one:

pci -v:

Class = Network (Ethernet)
Vendor ID = 16ech, U.S. Robotics
Device ID = 116h, USR997902 10/100/1000 Mbps PCI Network Card
PCI index = 0h
Class Codes = 020000h
Revision ID = 10h
Bus number = 0
Device number = 17
Function num = 0
Status Reg = 2b0h
Command Reg = 7h
Header type = 0h Single-function
BIST = 0h Build-in-self-test not supported
Latency Timer = 20h
Cache Line Size= 8h un-cacheable
PCI IO Address = dc00h length 256 enabled
PCI Mem Address = ef000000h 32bit length 256 enabled
Subsystem Vendor ID = 16ech
Subsystem ID = 116h
PCI Expansion ROM = 0h length 131072 disabled
Max Lat = 64ns
Min Gnt = 32ns
PCI Int Pin = INT A
Interrupt line = 11
CPU Interrupt = bh
Capabilities Pointer = dch
Capability ID = 1h - Power Management
Capabilities = f7c2h - 100h

while ifconfig -a doesn’t show anything.

Is any manual installation possible?

Thanks in advance,

P.S. I have Neutrino 6.3.0 SP3 + Core 6.3.2A.


If ‘ifconfig -a’ doesn’t show the card then you need to do 2 things:

  1. Go to the QNX website and make sure your card is on the supported list of ethernet cards … index.html

  1. Assuming your card is on that list, then you’ll need to slay io-net and then manually start it with the correct driver. For more help look in the helpview under io-net.

Normally io-net is started with the generic command of:

io-net -ptcpip

But you might need to do something like

io-net -dne2000 -ptcpip (note this is an example, not the driver you need)

There are a host of further options for specifying PCI slot etc if that still doesn’t work (personally I have never had to go beyond something like the line above)


  1. Unluckily :frowning: my hardware is not explicitely supported
  2. I was hoping that some driver could work anyway

I will play my last card with the io-net command.
Is it advisable to put it into rc.local?

Thank you very much :slight_smile: ,


If no driver is explicitly supported I’d be VERY surprised if another one worked. I had a 1Gig intel card in 6.3 SP2 that was not supported and no matter what options I gave to the intel driver it never worked. Lucky that card now is supported in SP3 :slight_smile:

As for the commands, you can put it in rc.local but I’d recommend you do it in /etc/system/sysinit.

The only reason is that other process’s/daemons may start later in sysinit or rc.sysinit that depend on io-net and if you later slay it and restart it those may need to be restarted too (or not, you just have to experiment)


The real method is to add the PCI vendor and device in the devices list file. Off hand I don’t remember where that file is /etc/system/… ???

sysinit should not be modified by user, it could be overwritten by patches/updates.