Problem with keyboard!!

Hi
I’m using QNX6.2.1 and I’ve a problem with the keyboard …
Under Photon, I put the keyboard in azerty and no problem when I used qnx with photon.
But when I want to work in console mode, the keyboard is in qwerty mode …
And I’ve not found how to change that …

Could you help me please!!!

As far as I remember this is set by devc-* (devc-hid, devc-con or smilar), but not sure

I just took a look into our QNX4, there was a binary called kbd, this is not found on neutrino :frowning:

Thank you,

yes in qnx4, it’s easy to change but I’ve not found the same in qnx6 …
the devc-con is a binary file… Can I change it?
Or perhaps I’m not in the good repository …

Sorry, I had not understood your response the first time :blush:

I’ve not found the option to use to choose the keyboard…
do you know where the devc-con is launched?

thanks

i think its in your sysinit or in your buildfile

preferable in the sysinit:
/etc/system/sysinit

or buildfile (but i guess just the base-support is loaded there)
/boot/build/yourbuild.build

Check also /etc/config/ttys
but this i think just sets what to be run on console

thanks
I found where the devc-con is launched but i didn’t found an option to choose azerty keyboard :cry:

i found another interessting file, but i actually cannot take a look right now :stuck_out_tongue_winking_eye: i collapsed my system by recursive shellscript G In old QNX this was handled and the process just died …
In new QNX i used up all my memory now :stuck_out_tongue_winking_eye:

File is /et/config/ttys i think it was

:smiley: good luck!!!

thanks I will take a look on this file!!!

I found the file and I just have these lines :
con1 “/bin/login” qansi-m on
and the same line for 4 console…

Have you got an idea how to use this file/line?

thanks

There was another file i was looking at, sry, got no time now anymore, will take alook tomorrow and post then :slight_smile:
HF

thank you very much!!! :wink: