USB fsys.umass on 4.25E

Alright, I’m trying to get the usb drivers to work on an IBM x205 server.

I start up io-usb, and the /dev/usb shows up.

I start up Fsys.umass, and it finds the generic flash drive, but doesn’t ever add anything to the /dev directory. I’m under the impression that it’s supposed to do that so I can have something to mount.

Anyone have any ideas?


Yes it should add /dev/hd? ( what ever number comes up next).

If you run the command “usb” is the device listed and listed as a recognized device?

I use usb for QNX4.25 on different computers in the office. It works on most of the Computers with most of the USB-sticks I use.

I know from experience, that if the io-usb isn’t dropping, it should work in general.

I call the Fsys.umass as follows: Fsys.umass fsys -n0=hd_usb &
With the n0 option, you force the device name. In this case, it will be /dev/hd_usb0

When Fsys.umass is startet you get a response as “Hama USB-Stick found”…

Start the Fsys.umass with -vvv and try the usb (-vvv) tool, as mario said.

I have seen one USB-Stick, wich is detected as floppy /dev/fd1, but it works anyway if you mount it as usual.



Sorry for the delay. When I run “usb”, it pops up:

USB0 (EHCI) v1.10, v1.01 DDK, V1.01 HCD

USB1 (EHCI) v1.10, v1.01 DDK, V1.01 HCD

USB2 (EHCI) v1.10, v1.01 DDK, V1.01 HCD

Device Address : 1
Vendor : 0x058f (Generic)
Product : (Mass Storage Device)
Class : 0x00 (Independant per interface)

I currently have a /dev/hd0, and a /dev/hd0t77, and a /dev/fd0…but all of those were there before even messing with the usb and Fsys.umass stuff. I tried a lexar jump drive as well, and instead of saying “generic” it said “lexar”

I just tried this on a generic server, and it works just fine. Must be something with the chipset of this x205. Teh suck

how many usb controllers has it got? I found that often they are mixed UHCI and EHCI, and targetting only the UHCI with -pindex gives more luck