QNX tcp/ip protocol and subnetmask

Hallo everybody of this community!!

I’m a real new user of QNX and open OS, so I really know few about…everithing.
:question: :question: :question: :question:
But now I have to install an experimental set up which use QNX4.25

This system was perfectly operating in my lab in Munich, but now I’ve some problems with the subnetmask.

the problem is that the network administrator here gave me a class C IP address (195.xx.xx.xx), use a 0xfffffe00 subnet mask.

It seems to me that, when I use as IP address a C class IP, the system automatically set the subnet mask to 0xffffff00: in this way things doesn’t work,since it the network part of gateway and IPaddress are different, and I receive the error message “network unreachable” during the booting.
i can ping the machine within the network, but I can’t access the gateway to go out.

This problem is not related to the protocol used in this lab (they use dhcp), since I’ve the problem even when the cable is unplugged.

Any suggestion?

If you need more info,please ask, I’ll try to be more precise.

THank you for the help!

I vaguely recall TCP/IP version 4.25 not supporting class C.

I know that with version 5.0 it works.

Hallo Mario,

Thank you for your answer: I don’t really know if the problem is the fact that class C addresses are not supported: as I wrote, the poblem seems to be that QNX let using only subnetmask that are GREATER than the class of the address: I would have had the same problem if I had a classB address and I had to use a netmask <0xffff0000 (i.e.0xfffe0000). On the contrary, I wouldn’t have any problem if I have the gateway address and the IPaddress identical for the 24 MSB.
Anyone know if there is such automatic defoult setting of the subnet mask and if is it possible to avoid it?Otherwise, anyone can suggest me any workaround?

Thank you all

Check documentation on ifconfig.

Dear Mario,

I checked the ifconfig documentation:
The problem is that with an IPaddress > 192.x.x.x even with the command:

ifconfig en1 netmask 0xfffffe00 up

didn’t change the netmask.

Instead, if I have an IPaddress < 192.x.x.x
the same command works, and effectively changes the subnet mask specified in the etc/config/sysinit.x file.

That’s why I think there’s a defoult setting of the subnet mask:it may be possible I have to change something with the routed deamon?

Thank you for your answers!

I spoke with QNX supporting team: there is no solution :frowning:

The only think I can do is to pass to the .5 version…

Thank you all (expecially Mario) for your support!!