Start device driver from an Application

I use the system() API to execute or start a device driver from my application.
EX: system(devb-umass);
Are there any other ways apart from using system() ???

Please let me know the most effecient and error free method to start device drivers from an application.

The issue with this is some of the device errors like driver load failure, driver busy etc… cannot be trapped using the system() API. It oly gives me a 0 if success or 256 for any kind of error occured during the driver loading.


There is perror() and spawn()

I tried to use perror() but did not succeed.
system(“mount -t dos /dev/ver1 /device”)
perror("Mount error - ");

it still prints :

mount: Can’t mount /device (type dos)
mount: Possible reason: Invalid argument
Mount error - : =No error 0

Please help.

Did you read the documentation on perror()?

Now I have other issue. I started my usb device using the “devb-umass cam pnp disk name=mydev1” command.
then did a “ls /dev” it listed the device as “mydev10”. I was able to mount this device using the “mount -t dos /dev/mydev10 /musb” command.

Then I removed this usb stick and inserted another one, from other vendor. I typed the same command to load the device driver.
But this time I see two entries in the /dev folder. One is “mydev10” and the other is “mydev10t11”. Iam able to mount both of them, but
can access only the drive mounted using “mydev10t11”.

I dont knw why is this difference when I try the same command set for two devices. Please help.

Guessing you used 2 different USB Devices.
It looks a lot like the t11-part is the type of the partition, this would mean a Hidden Fat12 partition, this is kinda out of date :smiley:
It may be just some error so that it is guessed to be “hidden fat12”
you can try by fdisk /dev/mydev10, this should show the available partitions on the storage medium

Since this is USB u do not have to run the command again i think, would be enough to just umount your old stick, put the new one into usb-port, call the same mount and there we are ^^

Thanks a lot. But is there are way to generalise the mounting process. I mean that U should be able to mount any USB storage device.
does not matter wht FAT file system is present on it. is there a command or a option for tht.

i need to basically mount any usb stick irrespective of vendor that has fat file system. i tried using the automount=hd0t* option but does not work.